{read_block_error,<<"0">>} with level_db

Matthew Von-Maszewski matthewv at basho.com
Wed Jul 30 12:30:54 EDT 2014


There have been zero errors during the leveldb::ReadBlock call.

On Jul 30, 2014, at 12:19 PM, Bryan <bryan at go-factory.net> wrote:

> We are diagnosing a weird intermittent problem where we are getting an {error, disconnected} exception from the riak erlang client. There is not a lot of information generated on our side, other than we trying to do a request on a connection and get this error. We have our own connection pooling mechanism with 10 connections available to each node in the cluster.
> 
> When I do a vnode_status on one of the suspect nodes, I get a dozen of the following type of output. They all have the {read_block_error,<<“0”>>} tuple:
> 
> VNode: 45671926166590716193865151022383844364247891968
> Backend: riak_kv_eleveldb_backend
> Status:
> [{stats,<<"                               Compactions\nLevel  Files Size(MB) Time(sec) Read(MB) Write(MB)\n--------------------------------------------------\n  0        3        0         0        0         0\n">>},
>  {read_block_error,<<"0">>},
>  {fixed_indexes,true}]
> 
> So my question is pretty simple and just looking for clarification. How should this be read? 1) that there are 0 read_block_errors? Or 2)  that the read_block_error code is  <<“0”>>. 
> 
> Cheers,
> Bryan
> 
> 
> ----
> 
> Bryan Hughes
> Go Factory
> (415) 515-7916
> 
> http://www.go-factory.net
> 
> Connecting the Internet of Things
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20140730/e7d9c869/attachment.html>


More information about the riak-users mailing list