1.4.8, memory_backend max_memory not honored?

Allen Landsidel landsidel.allen at gmail.com
Tue Jun 24 13:49:11 EDT 2014


Thanks Christian,

Giving that a try while I build a new 1.4.9 test cluster.

On 6/24/2014 13:27, Christian Dahlqvist wrote:
> Hi Allen,
>
> Apart from the memory backend, AAE will also be consuming memory as you
> currently have it enabled. I would recommend running the test again with
> anti entropy turned off to see how much impact that has.
>
> Best regards,
>
> Christian
>
>
>
>
>
> On Tue, Jun 24, 2014 at 5:29 PM, Allen Landsidel
> <landsidel.allen at gmail.com <mailto:landsidel.allen at gmail.com>> wrote:
>
>     Sure Luke.
>
>     The app.config is attached.
>
>     Does that riak_kv/940 sound like it could be responsible?
>
>
>     On 6/24/2014 12:15, Luke Bakken wrote:
>
>         Hi Allen,
>
>         There were some fixes to the memory backend in 1.4.9:
>         https://github.com/basho/riak/__blob/1.4/RELEASE-NOTES.md
>         <https://github.com/basho/riak/blob/1.4/RELEASE-NOTES.md>
>
>         Could you please provide your app.config file? I'd like to check
>         it and
>         test out your scenario locally.
>
>         --
>         Luke Bakken
>         CSE
>         lbakken at basho.com <mailto:lbakken at basho.com>
>         <mailto:lbakken at basho.com <mailto:lbakken at basho.com>>
>
>
>
>         On Tue, Jun 24, 2014 at 8:59 AM, Allen Landsidel
>         <landsidel.allen at gmail.com <mailto:landsidel.allen at gmail.com>
>         <mailto:landsidel.allen at gmail.__com
>         <mailto:landsidel.allen at gmail.com>>> wrote:
>
>              Test cluster with 2 machines running 1.4.8 with the memory
>         backend.
>              app_config has ring_creation_size 64, max_memory 4.  If I
>         understand
>              the documentation correctly this should result in a maximum
>         memory
>              footprint (minus overhead) of 256M.  Each node has 2G RAM,
>         2G of
>              swap.  After running for a while constantly adding data,
>         without
>              ever explicitly removing any, the memory footprint outstrips
>              physical ram and will eventually consume all available swap
>         space
>              and be killed.
>
>              Is this a known issue in 1.4.8 that's fixed in 1.4.9, or is
>         there
>              other configuration settings that need adjusted to reduce
>         the footprint?
>
>              Initially I had set it up to top out at 1GB but when it started
>              exhausting swap, I progressively reduced max_memory until I
>         arrived
>              where I am now, with no difference at all.
>
>              ___________________________________________________
>              riak-users mailing list
>         riak-users at lists.basho.com <mailto:riak-users at lists.basho.com>
>         <mailto:riak-users at lists.__basho.com
>         <mailto:riak-users at lists.basho.com>>
>         http://lists.basho.com/____mailman/listinfo/riak-users_____lists.basho.com
>         <http://lists.basho.com/__mailman/listinfo/riak-users___lists.basho.com>
>
>         <http://lists.basho.com/__mailman/listinfo/riak-users___lists.basho.com
>         <http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com>>
>
>
>
>     _______________________________________________
>     riak-users mailing list
>     riak-users at lists.basho.com <mailto:riak-users at lists.basho.com>
>     http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>




More information about the riak-users mailing list