trouble enabling strong consistency in riak_2.0.0beta1-1

Andrew Stone astone at basho.com
Fri May 9 15:36:12 EDT 2014


Oops. Didn't reply to the list. Sorry for the dupe Matt.

Hi Matt,

My guess is that this has to do with a fairly recent change to the cluster
join mechanism.

Try attaching to the erlang shell with "riak attach" and running the
following command:

riak_ensemble_manager:enable().

In the future a riak_admin command (and documentation) will be provided,
but for now it needs to be done from the shell. Hope this helps.

-Andrew


On Fri, May 9, 2014 at 7:07 AM, Matt Williams
<matt.williams at geneity.co.uk>wrote:

> Hi,  I've been trying out the new strong consistency in v2.0, I have this
> working nicely in 2.0.0pre20, but I can't seem to enable this in
> 2.0.0beta1-1.
>
> Any call to a strongly consistent bucket just returns immediately with
> 'request timed out', previously 'not found'.  Bucket types without strongly
> consistent properties behave fine.
>
> I figure I must have done something stupid, but I can't figure out what,
> can anyone point me in the right direction?
>
> I am working with a fresh build of ubuntu:-
>
> Distributor ID: Ubuntu
> Description: Ubuntu 12.04.4 LTS
> Release: 12.04
> Codename: precise
>
> 'riak config effective' suggests strong consistency is turned on
> strong_consistency = on
>
> I'm working with just one node at the moment.
>
> Thanks,
>
> Matt
>
>
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20140509/29f2553a/attachment.html>


More information about the riak-users mailing list