Error starting riak server

Hector Castro hector at basho.com
Mon May 19 14:43:54 EDT 2014


Rachana,

What version of Erlang are you trying to build with? I do not think
that basho_bench has support for OTP 17.

I built basho_bench successfully with R16B02.

--
Hector


On Mon, May 19, 2014 at 5:23 AM, Rachana Shroff <rshroff at tibco.com> wrote:
> Hi Brian, Hector,
>
> I want to run the riak benchmark tests and following below steps and stuck
> at error below-
>
> $ git clone git://github.com/basho/basho_bench.git
> $ cd basho_bench
> $ make [also tried make all]
>
> I am hitting below error -
>
> ERROR: compile failed while processing
> /home/apps/AS/riak-1.4.8/basho_bench/deps/riakc: rebar_abort
> make: *** [compile] Error 1
>
> Could you please help me with some pointers to be try out?
>
> Also based on this i have few queries like what kind od schema is been used
> in benchmarking, are there any multi-threadig feature enabled, can multiple
> clients be launched at same time, Is there any batch enabled on to and fro
> data from cache?
>
>
> Appreciate quick help.
>
> Thanks,
> Rachana
>
>
>
> On Thu, May 15, 2014 at 4:02 PM, Rachana Shroff <rshroff at tibco.com> wrote:
>>
>> Hi Hector, Brian:
>> Thanks for your quick response and sorry couldn't get back to you.
>> I did installation using rpm earlier but didn't worked for me. So went for
>> source installation.
>> Anyways, i did installation again using rpm and it worked.
>>
>> I wanted to run the benchmark bundled with it.
>>
>> Currently i am exploring this and would get back to you for any issues
>> running same.
>>
>>
>>
>> Thanks & Regards,
>> Rachana
>>
>>
>> On Sat, May 10, 2014 at 12:31 AM, Brian Roach <roach at basho.com> wrote:
>>>
>>> Looking at your logs, they all show:
>>>
>>> Error loading "erlang_js_drv": "Driver compiled with incorrect version
>>> of erl_driver.h"
>>>
>>> In your post you say you installed:
>>>
>>> "Erlang - First otp_src_R14B02 and then otp_src_R15B01"
>>>
>>> More than likely you've compiled Riak with the old version or erlang.
>>>
>>> As Hector mentioned, you may want to use an RPM rather than building
>>> from source. You also want to remove R14B02 or at the very least make
>>> sure it's not in your path.
>>>
>>> - Roach
>>>
>>>
>>>
>>>
>>>
>>> On Fri, May 9, 2014 at 10:39 AM, Hector Castro <hector at basho.com> wrote:
>>> > Hi Rachana,
>>> >
>>> > Is there any reason why you didn't elect to install via RPM? [0] That
>>> > path may be easier to get started with than compiling Erlang and Riak
>>> > from source, as we bundle Erlang into the RPM.
>>> >
>>> > --
>>> > Hector
>>> >
>>> > [0]
>>> > http://docs.basho.com/riak/latest/ops/building/installing/rhel-centos/
>>> >
>>> > On Fri, May 9, 2014 at 5:47 AM, Rachana Shroff <rshroff at tibco.com>
>>> > wrote:
>>> >> Hi,
>>> >>
>>> >> I am exploring Riak 1.4.8 and facing issue starting riak server.
>>> >> Additional details are-
>>> >> OS - Linux
>>> >> Red Hat Enterprise Linux Server release 6.1 (Santiago)
>>> >> 2.6.32-131.0.15.el6.x86_64
>>> >>
>>> >> Erlang - First otp_src_R14B02 and then otp_src_R15B01
>>> >>
>>> >> I followed all installations steps from
>>> >> http://docs.basho.com/riak/1.3.0/tutorials/installation
>>> >>
>>> >> steps used for Erlang-
>>> >>
>>> >> wget http://erlang.org/download/otp_src_R15B01.tar.gz
>>> >> tar zxvf otp_src_R15B01.tar.gz
>>> >> cd otp_src_R15B01
>>> >> ./configure && make && sudo make install
>>> >>
>>> >>
>>> >> steps used for Riak-
>>> >>
>>> >> tar zxvf riak-1.4.8.tar.gz
>>> >> cd riak-1.4.8
>>> >> make rel
>>> >>
>>> >> After installation i am trying to start riak server but failing to do
>>> >> so.
>>> >>
>>> >> /../riak-1.4.8/rel/riak/bin>riak start
>>> >>
>>> >> Error Ouput - Node 'riak at 127.0.0.1' not responding to pings.
>>> >>
>>> >>
>>> >> I tried all the below workarounds suggested on the foroums but no
>>> >> luck.
>>> >>
>>> >> 1-
>>> >> ulimit -n
>>> >> 100000
>>> >> 2- change the ip to machine ip in vm.args and app.config.
>>> >> riak stop # stop the node
>>> >> riak-admin down riak at 127.0.0.1 # take it down
>>> >> sudo rm -rf /var/lib/riak/ring/* # delete the riak ring
>>> >> sudo sed -i "s/127.0.0.1/`hostname -i`/g" /etc/riak/vm.args # Change
>>> >> the
>>> >> name in config
>>> >> riak-admin cluster force-replace riak at 127.0.0.1 riak@"`hostname -i`" #
>>> >> replace the name
>>> >>
>>> >> riak start # start the node
>>> >>
>>> >> 3- restart server
>>> >>
>>> >>
>>> >> I have attached all log files.
>>> >>
>>> >>
>>> >> Would appreciate your quick support on this.
>>> >>
>>> >>
>>> >> Thanks & Regards,
>>> >> Rachana
>>> >>
>>> >>
>>> >> _______________________________________________
>>> >> riak-users mailing list
>>> >> riak-users at lists.basho.com
>>> >> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>> >>
>>> >
>>> > _______________________________________________
>>> > riak-users mailing list
>>> > riak-users at lists.basho.com
>>> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>




More information about the riak-users mailing list