Upgrading 1.4 to 2.0

Luke Bakken lbakken at basho.com
Thu Oct 2 11:53:24 EDT 2014


Hello,

Were you able to resolve this issue? I tried to reproduce your issue
but could not - the upgrade worked successfully.

When you execute "riak stop" prior to using dpkg to upgrade to 2.0,
please ensure all beam.smp processes are gone before doing the
upgrade.
--
Luke Bakken
Engineer / CSE
lbakken at basho.com


On Wed, Sep 24, 2014 at 7:19 AM, Thelonious Fonk <simonisimo at gmail.com> wrote:
> Hi all,
>
> I'm a total newbie with Riak so I apologize if my question is silly.
>
> I need to build a POC with Riak and we have 5 nodes running v1.4 on a dev
> box so the first thing I'm trying to do is to upgrade these nodes to v2.0
> On the first node (dev1) I followed the instructions here:
> http://docs.basho.com/riak/latest/ops/upgrading/rolling-upgrades/#Debian-Ubuntu
>
> But when I get to step 5 "5. Verify Riak is running the new version" the
> output of the "riak-admin status" command says
> /riak_api_version : <<"1.4.2-0-ga7e00e2">>
> riak_pipe_version : <<"1.4.2-0-g59d1bae">>
> riak_core_version : <<"1.4.2">>/
>
> I tried a second time and now when I re-install the package with dpkg -i
> the output says
> /(Reading database ... 52512 files and directories currently installed.)
> *Preparing to replace riak 2.0.0-1* (using riak_2.0.0-1_amd64.deb) ...
> Unpacking replacement riak ...
> Setting up riak (2.0.0-1) ...
> Processing triggers for man-db .../
>
> So this makes me think it detects somehow that version 2.0.0-1 is running
> but riak-admin still says 1.4.2...
>
> What am I doing wrong?
>
> Thanks for your help!
>
>
>
> --
> View this message in context: http://riak-users.197444.n3.nabble.com/Upgrading-1-4-to-2-0-tp4031821.html
> Sent from the Riak Users mailing list archive at Nabble.com.
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com




More information about the riak-users mailing list