Upgrading 1.4 to 2.0

Thelonious Fonk simonisimo at gmail.com
Thu Oct 2 12:38:57 EDT 2014


Thanks for looking into this Luke.

I wasn't able to solve this issue but since it was a dev environment, I
ended up uninstalling 1.4.2 and installing 2.0.0.
I did stop each node before upgrading it but I didn't look at beam
processes to make sure they were actually gone. I was surprised to see no
error and to see that the upgrade process could somehow detect that 2.0.0
was installed even though riak-admin status was showing 1.4.2. Weird...

Thanks again.
Simon

On Thu, Oct 2, 2014 at 5:54 PM, Luke Bakken [via Riak Users] <
ml-node+s197444n4031876h29 at n3.nabble.com> wrote:

> Hello,
>
> Were you able to resolve this issue? I tried to reproduce your issue
> but could not - the upgrade worked successfully.
>
> When you execute "riak stop" prior to using dpkg to upgrade to 2.0,
> please ensure all beam.smp processes are gone before doing the
> upgrade.
> --
> Luke Bakken
> Engineer / CSE
> [hidden email] <http://user/SendEmail.jtp?type=node&node=4031876&i=0>
>
>
> On Wed, Sep 24, 2014 at 7:19 AM, Thelonious Fonk <[hidden email]
> <http://user/SendEmail.jtp?type=node&node=4031876&i=1>> wrote:
>
> > Hi all,
> >
> > I'm a total newbie with Riak so I apologize if my question is silly.
> >
> > I need to build a POC with Riak and we have 5 nodes running v1.4 on a
> dev
> > box so the first thing I'm trying to do is to upgrade these nodes to
> v2.0
> > On the first node (dev1) I followed the instructions here:
> >
> http://docs.basho.com/riak/latest/ops/upgrading/rolling-upgrades/#Debian-Ubuntu
> >
> > But when I get to step 5 "5. Verify Riak is running the new version" the
> > output of the "riak-admin status" command says
> > /riak_api_version : <<"1.4.2-0-ga7e00e2">>
> > riak_pipe_version : <<"1.4.2-0-g59d1bae">>
> > riak_core_version : <<"1.4.2">>/
> >
> > I tried a second time and now when I re-install the package with dpkg -i
> > the output says
> > /(Reading database ... 52512 files and directories currently installed.)
> > *Preparing to replace riak 2.0.0-1* (using riak_2.0.0-1_amd64.deb) ...
> > Unpacking replacement riak ...
> > Setting up riak (2.0.0-1) ...
> > Processing triggers for man-db .../
> >
> > So this makes me think it detects somehow that version 2.0.0-1 is
> running
> > but riak-admin still says 1.4.2...
> >
> > What am I doing wrong?
> >
> > Thanks for your help!
> >
> >
> >
> > --
> > View this message in context:
> http://riak-users.197444.n3.nabble.com/Upgrading-1-4-to-2-0-tp4031821.html
> > Sent from the Riak Users mailing list archive at Nabble.com.
> >
> > _______________________________________________
> > riak-users mailing list
> > [hidden email] <http://user/SendEmail.jtp?type=node&node=4031876&i=2>
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
> _______________________________________________
> riak-users mailing list
> [hidden email] <http://user/SendEmail.jtp?type=node&node=4031876&i=3>
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
> ------------------------------
>  If you reply to this email, your message will be added to the discussion
> below:
>
> http://riak-users.197444.n3.nabble.com/Upgrading-1-4-to-2-0-tp4031821p4031876.html
>  To unsubscribe from Upgrading 1.4 to 2.0, click here
> <http://riak-users.197444.n3.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4031821&code=c2ltb25pc2ltb0BnbWFpbC5jb218NDAzMTgyMXwtMTM1MDQyMzQ1Ng==>
> .
> NAML
> <http://riak-users.197444.n3.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>




--
View this message in context: http://riak-users.197444.n3.nabble.com/Upgrading-1-4-to-2-0-tp4031821p4031881.html
Sent from the Riak Users mailing list archive at Nabble.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20141002/fbc59c11/attachment.html>


More information about the riak-users mailing list