Riak CS Authorization Problems

Kota Uenishi kota at basho.com
Sun Oct 26 21:49:19 EDT 2014


Lucas,

Thank you for being interested in Riak CS.

> s3cmd ls and retrieving the admin user works fine but I am not able to
create a new bucket.

That is typical observation when Stanchion is not correctly configured. I'm
afraid you didn't put admin key and secret into Stanchion's app.config.
Otherwise you just missed IP address or port number?

If that's the case or not, I admit it's not so easy to debug the config.

On Sunday, October 26, 2014, Lukas Welte <lukas.welte at aventris.com> wrote:

> Hey folks,
>
> I wanted to play around with Riak CS to build up a own S3.
> The Riak cluster is running perfectly (saving and retrieving data and so
> on) and also Riak CS seems to be up, cause I was able to create a user.
> I then setted this user in the config to be the admin user and configured
> s3cmd to use this user.
> s3cmd ls and retrieving the admin user works fine but I am not able to
> create a new bucket.
>
> How is this possible and where should I start debugging?
> I have no real idea where the problem could be as Riak is there and Riak
> CS is able to communicate to Riak.
>
> Would love to hear some ideas what I can try.
>
> Best regards,
> Lukas
>
>

-- 
Sent from Gmail Mobile
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20141027/a3054051/attachment.html>


More information about the riak-users mailing list