Rolling upgrade from 1.2 to 2.0

John Daily jdaily at basho.com
Fri Sep 19 10:39:09 EDT 2014


Basho only tests and supports upgrades 2 major releases forward, so 1.3 or
1.4 can be upgraded to 2.0, but 1.2 may or may not work.

I'd strongly recommend upgrading to 1.4.10 before moving to 2.0.

Some useful links:
* http://docs.basho.com/riak/latest/ops/upgrading/rolling-upgrades/
* http://docs.basho.com/riak/latest/ops/upgrading/production-checklist/
* http://docs.basho.com/riak/latest/upgrade-v20/

-John

On Thu, Sep 18, 2014 at 8:38 PM, Berend Ozceri <berend at eyefi.com> wrote:

> Could someone please point me toward some authoritative documentation on
> whether a Riak cluster running version 1.2 can be upgraded in rolling
> fashion to 2.0 directly, without going through an intermediate release? We
> generally held back on 1.4 due to some of the growing pains we perceived
> around that release, but are interested in moving to 2.0 in a timely
> fashion.
>
> Thanks,
>
> Berend
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20140919/a90a3b2f/attachment.html>


More information about the riak-users mailing list