riak-erlang-client

Russell Brown russell.brown at me.com
Mon Sep 29 12:20:29 EDT 2014


Have you included the deps/riak_pb/ebin in your erlang path?

On 29 Sep 2014, at 17:18, Jon Brisbin <jon at jbrisbin.com> wrote:

> I’m trying to use the riak-erlang-client from master to talk to Riak 2.0 and I’m getting an error when I use the test commands found in the README:
> 
> (rabbit at localhost)1> {ok, Pid} = riakc_pb_socket:start_link("127.0.0.1", 8087).
> {ok,<0.685.0>}
> (rabbit at localhost)2> riakc_pb_socket:ping(Pid).
> ** exception exit: undef
>      in function  riak_pb_messages:msg_code/1
>         called as riak_pb_messages:msg_code(rpbpingreq)
>      in call from riak_pb_codec:encode/1 (src/riak_pb_codec.erl, line 73)
>      in call from riakc_pb_socket:encode_request_message/1 (src/riakc_pb_socket.erl, line 2094)
>      in call from riakc_pb_socket:send_request/2 (src/riakc_pb_socket.erl, line 2077)
>      in call from riakc_pb_socket:handle_call/3 (src/riakc_pb_socket.erl, line 1258)
>      in call from gen_server:handle_msg/5 (gen_server.erl, line 585)
>      in call from proc_lib:init_p_do_apply/3 (proc_lib.erl, line 239)
> 
> Do I have something wrong here? I have installed the riak-erlang-client .ez file as a RabbitMQ plugin via dependency from my riak-exchange plugin, which I’m trying to get updated to 2.0.
> 
> Any thoughts?
> 
> 
> Thanks!
> 
> Jon Brisbin
> http://jbrisbin.com
> @JonBrisbin | @mformonochrome
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20140929/759f35a7/attachment.html>


More information about the riak-users mailing list