Query on Riak Search in a cluster of 3 nodes behind ELB is giving different result everytime

Santi Kumar santi at veradocs.com
Wed Apr 1 04:02:42 EDT 2015


n_val is 3 for us and we have 3 nodes
On Apr 1, 2015 1:21 PM, "Vitaliy E" <13vitamins at gmail.com> wrote:

> Hello everyone,
>
> I've just joined the list, and am a bit late to the party. Sorry about
> that. Thought I would contribute an answer anyway.
>
> Santi, what is you n_val?
>
> I observed the behavior you are describing on Riak 2.0.0 with n_val=3 in
> two cases:
>
> 1. One of the nodes was not part of the cluster although the cluster was
> thinking it was. Don't ask me how that happened. Obviously, when a request
> hit that node part of the entries could not be found there.
>
> 2. Look for indexing errors in Solr console and Riak logs. Each Riak node
> has its own Solr "repository", so if an entry fails to be indexed on any of
> them, search results will be inconsistent depending on which set of nodes
> returns it. Let's say you have replicas on nodes A, B, and C. Entry X
> failed to be indexed on A, entry Y failed to be indexed on A and B, and
> entry Z was indexed OK on all nodes. Then you may get {X,Y,Z}, {X,Z}, or
> {Z} as your search results.
>
> In our case the indexing failures were caused by disk/filesystem errors.
>
> Regards,
> Vitaly
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150401/4ee8b4ef/attachment-0002.html>


More information about the riak-users mailing list