Different results to same queries

Sadykov Rustem sadrust at gmail.com
Wed Apr 22 12:45:55 EDT 2015


Hello.
I'm testing riak 1.4.10 on 2 node cluster (on different servers), but result is same on 3 nodes cluster and on single node also.

I try to count records in my bucket and always get 3-4 different results.
Query is:

curl -XPOST http://localhost:8098/mapred -H 'Content-Type: application/json' -d '{"inputs":"account", "query":[{"reduce":{"language":"erlang", "module":"riak_kv_mapreduce", "function":"reduce_count_inputs", "arg":{"reduce_phase_batch_size":1000} } }] }'

on every execution I get one of theese results (data on DB are not changing during tests):
[7321]
[6985]
[7339]

If I run same query on bigger bucket, then I can get 3-4 different results.

I tried to repair 2i indexes and repair partitions, but nothing helps.

Maybe someone can help me? How can I fix this strange behavior?

--
Rustem.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150422/c6c4f9f5/attachment-0002.html>


More information about the riak-users mailing list