RiakCS - AWS-CLI command works but Node.js API fails

Dattaraj J Rao dattarajrao at yahoo.com
Tue Dec 1 03:18:49 EST 2015

Thanks Shino for your response. 

I tried providing the buclet url as endpoint - also tried setting s3endpoint to true. Same problem.

Surprisingly the command line tool works fine.


-----Original Message-----
From: Shunichi Shinohara <shino at basho.com>
Date: Mon, 30 Nov 2015 10:26:48 
To: Dattaraj Rao<dattarajrao at yahoo.com>
Cc: riak-users at lists.basho.com<riak-users at lists.basho.com>
Subject: Re: RiakCS - AWS-CLI command works but Node.js API fails

Hi Dattaraj,

I'm not sure how AWS SDK JS works in detail, I'm wondering whether
it's good to include
S3/CS bucket name in endpoint string.  One example of the doc [1], it does not
have bucket name part.

[1] http://docs.aws.amazon.com/AWSJavaScriptSDK/latest/AWS/Endpoint.html


2015-11-28 23:13 GMT+09:00 Dattaraj Rao <dattarajrao at yahoo.com>:
> Hello,
> I am trying to access a RiakCS data store. I can access it using following
> command in AWS-CLI:
> $ aws s3 --endpoint-url https://my-riak-address.io cp my-local-file
> s3://service-instance-e689c062-dee6-45d7-90fe-39e63256915f
> However when I try connecting to same repository using Node JS and AWS-SDK
> bunlde - it does not connect. Says endpoint not exposed.
> var AWS = require('aws-sdk');
> AWS.config.update({accessKeyId: 'mykey', secretAccessKey: 'mysecret'});
> var ep = new
> AWS.Endpoint('https://my-riak-address.io/service-instance-e689c062-dee6-45d7-90fe-39e63256915f');
> var s3 = new AWS.S3({endpoint: ep});
> Regards,
> Dattaraj
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

More information about the riak-users mailing list