Riak 2.1 on FreeBSD 10

Kinson Chan 陳傑信 kinsonchan at clustertech.com
Sun Dec 6 11:17:43 EST 2015


Hi,

I just tried installing Riak 2.1.x on a cluster of FreeBSD 10.  It was not as smooth as what I experienced on that other operating system...

My first attempt is installing the downloaded .txz file.  The pkg was already smart enough to download compat9x, but glibc is still missing.  (By the way, can I get one compiled with clang? :-)

> 2015-12-06 23:20:22.610 [warning] <0.187.0> The on_load function for module eleveldb returned {error,{load_failed,"Failed to load NIF library: '/usr/local/lib/compat/libstdc++.so.6: version GLIBCXX_3.4.11 required by /usr/local/lib/riak/lib/eleveldb-2.1.4-0-ged3a072/priv/eleveldb.so not found'"}}


I then tired installing from the official package site.  This time pkg was smart enough to list all other required dependencies.  After enabling riak in /etc/rc.conf, I tried to start the service, and it failed within a second:

> su: no directory


After digging through the /usr/local/sbin/riak, I realised the riak user has an non-existent home – /usr/local/riak.  It works after I made one for it.

Regards,
Kinson



More information about the riak-users mailing list