Riak python client and Solr

Joe Olson technology at nododos.com
Mon Dec 14 08:34:13 EST 2015


I am trying to use the Solr ( Yokozuna ) 'group' options with fulltext_search. I get expected results when I use the http interface, but not with python-riak-client fulltext pbc search.
Here's what I'm trying to do: 

# This works fine 
curl "http://<IP ADDRESS>:8098/search/query/solrdefault?wt=json&q=id_s:myID&group=true&group.field=groupBy_s" | jsonpp 


# This does not work. 'group.field' not recognized as a valid param. 
result = client.fulltext_search('solrdefault', 'id_s:myID', group='on', group.field='groupBy_s') 

# Tried several variations on 'group.field' param...quoting, groupfield, field, etc 
# Also tried tracing through github to find appropriate param. Came up empty. Dead end @ transports/transport.py (function def search). 

Does anyone have 'group' working with Solr using the Python client?? 

(This question has been asked on this mailing list before, but there is no documented resolution.) 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20151214/7aa01544/attachment-0002.html>


More information about the riak-users mailing list