riakc_pb_socket process crash with "ERROR REPORT" when doing any operation on riak

mmartin4242 mmartin4242 at gmail.com
Sat Feb 7 10:29:02 EST 2015


Make sure you are connecting to the protocol buffer port, and not the http port.



Sent from my T-Mobile 4G LTE Device


-------- Original message --------
From: YouBarco <barcojie at hotmail.com> 
Date:02/07/2015  08:11  (GMT-07:00) 
To: riak-users at lists.basho.com 
Cc:  
Subject: riakc_pb_socket process crash with "ERROR REPORT" when doing any	operation on riak 

When I trying to do any operation on riak node through riakc_pb_socket process, the process crash as following, Could you please tell what the problems is? Thank you!

OS: Ubuntu 14.10 64 bit , riak: 2.0.4 built from source,  erlang: 17

(aaa at 127.0.0.1)7> {ok, Pid2} = riakc_pb_socket:start_link("10.0.3.99", 10018).
{ok,<0.775.0>}
(aaa at 127.0.0.1)8> riakc_pb_socket:get_bucket(Pid2, <<"user">>).               

=ERROR REPORT==== 7-Feb-2015::23:02:07 ===
** Generic server <0.775.0> terminating 
** Last message in was {tcp_closed,#Port<0.1414>}
** When Server state == {state,"10.0.3.99",10018,false,false,undefined,false,
                               gen_tcp,undefined,
                               {[],[]},
                               1,[],infinity,undefined,undefined,undefined,
                               undefined,[],100}
** Reason for termination == 
** disconnected
** exception exit: disconnected

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150207/069708a3/attachment-0002.html>


More information about the riak-users mailing list