RIAK-CS Unable to create bucket using s3cmd - AccessDenied...

Ambert Ho ambert at pubnub.com
Fri Feb 6 21:08:07 EST 2015


Hi,

I have the following setup: riak 1.4.12, riakcs 1.5.3, stanchion 1.5.0

I am able to list bucket contents, and the authentication works (I get a
response when listing or trying to remove a bucket, PUT a file) but get an
AccessDenied error when trying to create a bucket.

I found this thread
http://riak-users.197444.n3.nabble.com/RIAK-CS-Unable-to-create-bucket-using-s3cmd-AccessDenied-td4032375.html
and tried adding signature_v2 = True to .s3cfg with no success, and I've
also tried three versions of s3cmd (1.5.0, 1.5.0alpha, 1.0.1) I also tried
creating a bucket using the python library boto, which also gives an access
denied error.
I'm stumped :( any suggestions on where I should look next would be greatly
appreciated! Not sure where there are logs for individual operations
against Riak-cs - I've set lager log level to debug and wasn't able to see
anything in the logs.

Thanks!
Ambert
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150206/a56f78bb/attachment-0002.html>


More information about the riak-users mailing list