Riak 2.0.4 Search AAE

Zeeshan Lakhani zlakhani at basho.com
Wed Feb 18 09:49:32 EST 2015


Hey Steve, I’ve run AAE manually by running `riak attach` on a running node and calling https://github.com/basho/yokozuna/blob/develop/src/yz_entropy_mgr.erl#L142 <https://github.com/basho/yokozuna/blob/develop/src/yz_entropy_mgr.erl#L142> (yz_entropy_mgr:init([])).

Nonetheless, to take a closer look, is there any data within search’s data-directory? You can find out by looking in ./data/yz_anti_entropy (on any of nodes). You can find more info in our docs, http://docs.basho.com/riak/latest/ops/advanced/configs/search/ <http://docs.basho.com/riak/latest/ops/advanced/configs/search/>, about search’s config settings.
 
Zeeshan Lakhani
programmer | 
software engineer at @basho | 
org. member/founder of @papers_we_love |
twitter => @zeeshanlakhani

> On Feb 18, 2015, at 9:03 AM, Steve Garon <steve.garon at gmail.com> wrote:
> 
> Hi all, 
> 
> I seem to have trouble with aae on riak 2.0.4. Specifically the search aae. When I run the command 'riak-admin aae-status' everything seems fine but if I run the same command for search (riak-admin search aae-status) it seem like the search entropy trees have never been built and never do. All I get on every field is --. 
> 
> Any command I can run to force the trees to be built so I get consistent search results?  
> 
> Steve
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150218/a0a30c5b/attachment-0002.html>


More information about the riak-users mailing list