Yokozuna unpredictable result count

Cezary Kosko koskocezarym at gmail.com
Thu Feb 19 11:53:55 EST 2015


By './data/yz_anti_entropy' do you mean '/var/lib/riak/yz_anti_entropy' by
default or './data/yz_anti_entropy' inside each index's directory? If the
former - it's there, the latter - not. riak-admin search aae-status says
there's been some AAE activity in the past few hours.

Also I called yz_entropy_mgr:init([]) inside an attached erlang shell and
curl-ed the object, it's still the same.

Kind regards,
Cezary

2015-02-19 17:27 GMT+01:00 Zeeshan Lakhani <zlakhani at basho.com>:

> Thanks Cezary.
>
> Have you deleted this object at some point in your runs? Please make sure
> AAE is running by checking search’s AAE status, `riak-admin search
> aae-status`, and that data exists in the correct directory,
> `./data/yz_anti_entropy` (
> http://docs.basho.com/riak/latest/ops/advanced/configs/search/). You may
> just need to perform a read-repair by performing a fetch of the object
> itself first, before performing search queries again.
>
> Zeeshan Lakhani
> programmer |
> software engineer at @basho |
> org. member/founder of @papers_we_love |
> twitter => @zeeshanlakhani
>
> On Feb 19, 2015, at 10:35 AM, Cezary Kosko <koskocezarym at gmail.com> wrote:
>
> I have the exact same issue with regular http search queries, so I guess
> I'll just describe that part.
>
> I've got a bucket of maps-of-sets, 2 of them are entityId_set and
> timestamps_set. Its search index is called 'job' and it's only this bucket
> that's indexed.
>
> When I run
> curl
> "localhost:8098/search/query/job?wt=json&q=entityId_set:100000000000000000%20AND%20timestamps_set:%5B1419721530%20TO%201419721539%5D"
>
> (that's a query that is supposed to return exactly one result), the
> numFound field is either 0 or 1, it seems that I get both kinds of result
> in 10 consecutive requests (and the timeAllowed parameter I wrote about, it
> doesn't really help).
>
> That's the way they're handled in the schema:
>
>    <field name="entityId_set"      type="string"  indexed="true"
> stored="false" multiValued="true" />
>    <field name="timestamps_set"      type="string"  indexed="true"
> stored="false" multiValued="true" />
>
>
> Kind regards,
> Cezary
>
> 2015-02-19 16:04 GMT+01:00 Zeeshan Lakhani <zlakhani at basho.com>:
>
>> Hello Cezary,
>>
>> Firstly, are you able to retrieve your search result consistently when
>> not using doing a mapreduce job?
>>
>> To better help out, can you send a gist of the mapreduce code you’re
>> running? Thanks.
>>
>>
>> On Feb 18, 2015, at 9:13 PM, Cezary Kosko <koskocezarym at gmail.com> wrote:
>>
>> Hi,
>>
>> I've got a search index, and I'd like to run mapred job against that
>> index. The thing is, for a search query that should return exactly one
>> result, I sometimes (not always, yet not rarely) get none, i.e. the mapred
>> job returns an empty list instead of, say, a list containing a single
>> object. Did this only happen some time after uploading the data and then
>> was consistently giving the right results, I wouldn't object. However, it's
>> kind of an on-and-off situation - I get proper results, but then for a
>> brief period of time I don't and so on.
>>
>> I've read on a solr doc page that specifying a timeAllowed parameter in
>> the query can give it longer to gather results and help, but that can't be
>> specified in a mapred definition, or can it?
>>
>> Is there anything else I can look for?
>>
>> The data I'm querying is of the CRDT map-of-sets type, should that be of
>> any relevance.
>>
>> Kind regards,
>> Cezary
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150219/e78488d6/attachment-0002.html>


More information about the riak-users mailing list