2.0.5 compiled from source SOLR failed to start

Zeeshan Lakhani zlakhani at basho.com
Fri Feb 27 09:31:15 EST 2015


Hello Alexander,

Can you tell me which operating system you’re on, so we can test this out specifically? I wasn’t able to reproduce on my local setup.

Also, can you list (ls) out that `../lib/yokozuna-2.0.0-34-g122659d/priv` directory (mine is located at `../rel/riak/lib/yokozuna-2.0.0-34-g122659d/priv` for example)?

Thanks.

Zeeshan Lakhani
programmer | 
software engineer at @basho | 
org. member/founder of @papers_we_love |
twitter => @zeeshanlakhani

> On Feb 27, 2015, at 5:46 AM, Alexander Popov <mogadanez at gmail.com> wrote:
> 
> 2015-02-27 10:38:27.960 [info] <0.563.0>@yz_solr_proc:ensure_data_dir:219 No solr config found, creating a new one
> 2015-02-27 10:38:27.961 [info] <0.563.0>@yz_solr_proc:init:96 Starting solr: "/usr/bin/java" ["-Djava.awt.headless=true","-Djetty.home=/var/riak-dist/riak1/bin/../lib/yokozuna-2.0.0-34-g122659d/priv/solr","
> -Djetty.port=18093","-Dsolr.solr.home=/var/lib/riak1/yz","-DhostContext=/internal_solr","-cp","/var/riak-dist/riak1/bin/../lib/yokozuna-2.0.0-34-g122659d/priv/solr/start.jar","-Dlog4j.configuration=file:///
> var/riak-dist/riak1/etc/solr-log4j.properties","-Dyz.lib.dir=/var/riak-dist/riak1/bin/../lib/yokozuna-2.0.0-34-g122659d/priv/java_lib","-d64","-Xms1g","-Xmx3g","-XX:+UseStringCache","-XX:+UseCompressedOops"
> ,"-Dcom.sun.management.jmxremote.port=18985","-Dcom.sun.management.jmxremote.authenticate=false","-Dcom.sun.management.jmxremote.ssl=false","org.eclipse.jetty.start.Main"]
> 2015-02-27 10:38:28.004 [info] <0.7.0> Application yokozuna started on node 'riak1 at 10.0.0.133 <mailto:riak1 at 10.0.0.133>'
> 2015-02-27 10:38:28.007 [info] <0.7.0> Application cluster_info started on node 'riak1 at 10.0.0.133 <mailto:riak1 at 10.0.0.133>'
> 2015-02-27 10:38:28.033 [info] <0.198.0>@riak_core_capability:process_capability_changes:555 New capability: {riak_control,member_info_version} = v1
> 2015-02-27 10:38:28.035 [info] <0.7.0> Application riak_control started on node 'riak1 at 10.0.0.133 <mailto:riak1 at 10.0.0.133>'
> 2015-02-27 10:38:28.035 [info] <0.7.0> Application erlydtl started on node 'riak1 at 10.0.0.133 <mailto:riak1 at 10.0.0.133>'
> 2015-02-27 10:38:28.043 [info] <0.7.0> Application riak_auth_mods started on node 'riak1 at 10.0.0.133 <mailto:riak1 at 10.0.0.133>'
> 2015-02-27 10:38:28.307 [info] <0.563.0>@yz_solr_proc:handle_info:135 solr stdout/err: java.io.FileNotFoundException: No XML configuration files specified in start.config or command line.
>         
> 2015-02-27 10:38:28.308 [info] <0.563.0>@yz_solr_proc:handle_info:135 solr stdout/err:  at org.eclipse.jetty.start.Main.start(Main.java:502)
>         at org.eclipse.jetty.start.Main.main(Main.java:96)
>        
> Usage: java -jar start.jar [options] [properties] [configs]
>        java -jar start.jar --help  # for more information
> 2015-02-27 10:38:28.625 [error] <0.563.0> gen_server yz_solr_proc terminated with reason: {"solr OS process exited",251}
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150227/bc8ed991/attachment-0002.html>


More information about the riak-users mailing list