Riak Search having issues with custom schema

Santi Kumar santi at veradocs.com
Fri Jan 9 10:04:39 EST 2015


Hi,
We are having issues with Riak Search custom schema. Application has
multiple POJO's and we are using Java client to write into RIakKV.
Configured custom solr schema with indexed fields from all POJOs. After
adding the "Catch-All" field, solr is not indexing any fields from any of
the Pojo.

No errors in solr log also. Not having any clues why nothing is indexed
except the Riak fields. Here is how the fields are specified in solr
schema, not attaching everything. We have multiple indexes and buckets for
different pojos, but difined only one schema for all the indexes. Same
schema is being configured for each index. Would that be an issue? For
example for Access has seperate index and condition has seperate index. But
both fields for both of them are defined in one schema and passed to both
the indexes.

  <!--  Acess fields -->

    <field name="docId"  type="string"  indexed="true" stored="false" />

    <field name="resourceName"   type="string"  indexed="true" stored=
"false" />

    <field name="resourceId"   type="string"  indexed="true" stored="false"
/>

    <field name="grantor"   type="string"  indexed="true" stored="false" />

    <field name="policies"   type="string"  indexed="true" stored="false" />

    <field name="grantTime"   type="access_dt"  indexed="true" stored=
"false" />

    <field name="state"   type="string"  indexed="true" stored="false" />

    <!--  Acess fields -->

  <!-- AvailablePoclies -->

  <field name="policiesId"   type="string"  indexed="true" stored="false" />

  <field name="type"   type="string"  indexed="true" stored="false" />

  <!-- AvailablePoclies -->

  <!-- Condition -->

  <field name="ruleId"   type="string"  indexed="true" stored="false" />

  <field name="object"   type="string"  indexed="true" stored="false" />

  <field name="verb"   type="string"  indexed="true" stored="false" />

  <!-- Condition -->
Thanks
Santi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150109/e384632c/attachment-0002.html>


More information about the riak-users mailing list