Riak Search having issues with custom schema

Santi Kumar santi at veradocs.com
Fri Jan 9 11:55:24 EST 2015


Luke
It's application/json

Here is the curl command and output dump with content-type in bold

curl -v
http://127.0.0.1:8098/buckets/junit_MASTER-Policies/keys/2d29e759-8e30-499a-8ecc-98eb09eeaa9f

* About to connect() to 127.0.0.1 port 8098 (#0)

*   Trying 127.0.0.1...

* Adding handle: conn: 0x7fc91c008c00

* Adding handle: send: 0

* Adding handle: recv: 0

* Curl_addHandleToPipeline: length: 1

* - Conn 0 (0x7fc91c008c00) send_pipe: 1, recv_pipe: 0

* Connected to 127.0.0.1 (127.0.0.1) port 8098 (#0)

> GET
/buckets/junit_MASTER-Policies/keys/2d29e759-8e30-499a-8ecc-98eb09eeaa9f
HTTP/1.1

> User-Agent: curl/7.30.0

> Host: 127.0.0.1:8098

> Accept: */*

>

< HTTP/1.1 200 OK

< X-Riak-Vclock: a85hYGBgzGDKBVIcypz/fvbkCGZlMCUy5rEyzDdUOceXBQA=

< Vary: Accept-Encoding

* Server MochiWeb/1.1 WebMachine/1.10.5 (jokes are better explained) is not
blacklisted

< Server: MochiWeb/1.1 WebMachine/1.10.5 (jokes are better explained)

< Link: </buckets/junit_MASTER-Policies>; rel="up"

< Last-Modified: Fri, 09 Jan 2015 11:03:59 GMT

< ETag: "2z3JHmwDLjQuWdJEploYUi"

< Date: Fri, 09 Jan 2015 16:53:43 GMT

< *Content-Type: application/json*

< Content-Length: 688

<

* Connection #0 to host 127.0.0.1 left intact

{"id":null,"tenantId":"eb0a1917-9762-3dd3-a48f-a681d3061212","createdById":null,"createdBy":"SYSTEM","created":1420801439932,"lastUpdatedById":null,"lastUpdatedBy":"SYSTEM","lastUpdated":1420801439932,"policyId":"2d29e759-8e30-499a-8ecc-98eb09eeaa9f","searchId":"557134f2-3589-3fdb-927f-6a71e8098eee","name":"Collaborate","description":"Allow
editing of file
content","isDefault":true,"enable_edit":true,"disable_auth_on_open":true,"enable_copy_paste":"DISALLOW","enable_printing":false,"enable_offline":true,"offline_timeout":null,"time_bomb_duration":null,"enable_save_as":false,"disable_watermark":true,"disable_spotlight":true,"enable_screen_capture":false,"disable_onetime_use":true}

On Fri, Jan 9, 2015 at 10:16 PM, Luke Bakken <lbakken at basho.com> wrote:

> Can you retrieve the object using "curl" and let me know what the
> "Content-Type" header is when returned?
> --
> Luke Bakken
> Engineer
> lbakken at basho.com
>
>
> On Fri, Jan 9, 2015 at 8:44 AM, Santi Kumar <santi at veradocs.com> wrote:
> > No content type is specified explicitly. Directly object is passed to
> > StoreValue.Builder(). Some where I read that pojo is extracted as json.
> Am
> > I missing something?
> >
> > ..... Here is the code.
> >
> > Location user_locaiton = new Location(nameSpace, key);
> >
> > StoreValue storeUserOp = new StoreValue.Builder(object)
> >
> >         .withLocation(user_locaiton)
> >
> >         .withOption(StoreValue.Option.W, Quorum.allQuorum())
> >
> >         .build();
> >
> > RiakFuture<com.basho.riak.client.api.commands.kv.StoreValue.Response,
> > Location> storeValueOpFuture = client.executeAsync(storeUserOp);
> >
> > storeValueOpFuture.await();
> >
> > logger.debug("Stroed Values for "+key+" in Bucket "+bucket);
> >
> > if(!storeValueOpFuture.isSuccess() || storeValueOpFuture.isCancelled() ||
> > !storeValueOpFuture.isDone()){
> >
> > throw new
> >
> InternalServerException(InternalServerException.ErrorCode.RIAK_EROR,"Exception
> > while storing object against key "+key+" in Bucket "+bucket);
> >
> > }
> >
> >
> > On Jan 9, 2015 9:42 PM, "Luke Bakken" <lbakken at basho.com> wrote:
> >>
> >> How are you storing these objects? What "Content-Type" is being used?
> >> --
> >> Luke Bakken
> >> Engineer
> >> lbakken at basho.com
> >>
> >>
> >> On Fri, Jan 9, 2015 at 7:04 AM, Santi Kumar <santi at veradocs.com> wrote:
> >> > Hi,
> >> > We are having issues with Riak Search custom schema. Application has
> >> > multiple POJO's and we are using Java client to write into RIakKV.
> >> > Configured custom solr schema with indexed fields from all POJOs.
> After
> >> > adding the "Catch-All" field, solr is not indexing any fields from any
> >> > of
> >> > the Pojo.
> >> >
> >> > No errors in solr log also. Not having any clues why nothing is
> indexed
> >> > except the Riak fields. Here is how the fields are specified in solr
> >> > schema,
> >> > not attaching everything. We have multiple indexes and buckets for
> >> > different
> >> > pojos, but difined only one schema for all the indexes. Same schema is
> >> > being
> >> > configured for each index. Would that be an issue? For example for
> >> > Access
> >> > has seperate index and condition has seperate index. But both fields
> for
> >> > both of them are defined in one schema and passed to both the indexes.
> >> >
> >> >   <!--  Acess fields -->
> >> >
> >> >     <field name="docId"  type="string"  indexed="true" stored="false"
> />
> >> >
> >> >     <field name="resourceName"   type="string"  indexed="true"
> >> > stored="false" />
> >> >
> >> >     <field name="resourceId"   type="string"  indexed="true"
> >> > stored="false"
> >> > />
> >> >
> >> >     <field name="grantor"   type="string"  indexed="true"
> stored="false"
> >> > />
> >> >
> >> >     <field name="policies"   type="string"  indexed="true"
> >> > stored="false" />
> >> >
> >> >     <field name="grantTime"   type="access_dt"  indexed="true"
> >> > stored="false" />
> >> >
> >> >     <field name="state"   type="string"  indexed="true" stored="false"
> >> > />
> >> >
> >> >     <!--  Acess fields -->
> >> >
> >> >   <!-- AvailablePoclies -->
> >> >
> >> >   <field name="policiesId"   type="string"  indexed="true"
> >> > stored="false" />
> >> >
> >> >   <field name="type"   type="string"  indexed="true" stored="false" />
> >> >
> >> >   <!-- AvailablePoclies -->
> >> >
> >> >   <!-- Condition -->
> >> >
> >> >   <field name="ruleId"   type="string"  indexed="true" stored="false"
> />
> >> >
> >> >   <field name="object"   type="string"  indexed="true" stored="false"
> />
> >> >
> >> >   <field name="verb"   type="string"  indexed="true" stored="false" />
> >> >
> >> >   <!-- Condition -->
> >> >
> >> > Thanks
> >> > Santi
> >> >
> >> >
> >> > _______________________________________________
> >> > riak-users mailing list
> >> > riak-users at lists.basho.com
> >> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> >> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150109/da51fef0/attachment-0002.html>


More information about the riak-users mailing list