Different numFound request to riak search

Zeeshan Lakhani zlakhani at basho.com
Thu Mar 12 09:36:09 EDT 2015


Hello Roma, 

Have you deleted this object at some point in your runs? Please make sure AAE is running by checking search’s AAE status, `riak-admin search aae-status`, and that data exists in the correct directory, `./data/yz_anti_entropy` (http://docs.basho.com/riak/latest/ops/advanced/configs/search/). You may just need to perform a read-repair by performing a fetch of the object itself first, before performing search queries again.

Also, have you left or added nodes? I’m guessing that  even your 1 node instance is still running a cluster on that one node, right?

Thanks.

Zeeshan Lakhani
programmer | 
software engineer at @basho | 
org. member/founder of @papers_we_love | paperswelove.org
twitter => @zeeshanlakhani

> On Mar 12, 2015, at 5:59 AM, Roma Lakotko <roman at lakotko.ru> wrote:
> 
> Each request to riak search return different results. It's return different numFound.
> 
> I use request like this:
> 
> http://localhost:8098/search/query/assets?wt=json&q=type:*&sort=_yz_rk%20asc <http://localhost:8098/search/query/assets?wt=json&q=type:*&sort=_yz_rk%20asc>
> 
> If add start offset it can return:
> 
> http://localhost:8098/search/query/assets?wt=json&q=type:*&sort=_yz_rk%20asc&start=1247 <http://localhost:8098/search/query/assets?wt=json&q=type:*&sort=_yz_rk%20asc&start=1247>
> "response": {
>         "numFound": 1248,
>         "start": 1247,
>         "docs": [
>             {
>                 "_yz_id": "1*default*assets*fff63ecf-a0c4-4ecf-b24d-c493ca3a302f*44",
>                 "_yz_rk": "fff63ecf-a0c4-4ecf-b24d-c493ca3a302f",
>                 "_yz_rt": "default",
>                 "_yz_rb": "assets"
>             }
>         ]
>     }
> 
> On next request it return something like this
> 
> "numFound": 1224,
>         "start": 1247,
>         "docs": []
> 
> I have 1 node installation, and no process write to Riak.
> I have same problem this production cluster with 7 nodes.
> 
> Scheme for document
> 
> <?xml version="1.0" encoding="UTF-8" ?>
> <schema name="schedule" version="1.5">
>  <fields>
>    <field name="objectId"     type="string_ci"   indexed="true" stored="false" />
>    <field name="type"     type="string_ci"   indexed="true" stored="false" />
>    <field name="objectType"     type="string_ci"   indexed="true" stored="false" />
>    
>    <field name="contentType"     type="string_ci"   indexed="true" stored="false" />
>    <field name="properties"    type="string_ci"   indexed="true" stored="false" multiValued="true" />
>    <field name="tag"     type="string_ci"   indexed="true" stored="false" />
>    <field name="isUploaded"    type="boolean"     indexed="true" stored="false" />
>    <field name="published"    type="boolean"     indexed="true" stored="false" />
>    <field name="drm"    type="boolean"     indexed="true" stored="false" />
>    <field name="dateCreated" type="date" indexed="true" stored="false" />
> 
>    <!-- All of these fields are required by Riak Search -->
>    <field name="_yz_id"   type="_yz_str" indexed="true" stored="true"  multiValued="false" required="true"/>
>    <field name="_yz_ed"   type="_yz_str" indexed="true" stored="false" multiValued="false"/>
>    <field name="_yz_pn"   type="_yz_str" indexed="true" stored="false" multiValued="false"/>
>    <field name="_yz_fpn"  type="_yz_str" indexed="true" stored="false" multiValued="false"/>
>    <field name="_yz_vtag" type="_yz_str" indexed="true" stored="false" multiValued="false"/>
>    <field name="_yz_rk"   type="_yz_str" indexed="true" stored="true"  multiValued="false"/>
>    <field name="_yz_rt"   type="_yz_str" indexed="true" stored="true"  multiValued="false"/>
>    <field name="_yz_rb"   type="_yz_str" indexed="true" stored="true"  multiValued="false"/>
>    <field name="_yz_err"  type="_yz_str" indexed="true" stored="false" multiValued="false"/>
> 
>    <dynamicField name="*" type="ignored"/>
>  </fields>
> 
>  <uniqueKey>_yz_id</uniqueKey>
> 
>  <types>
>   <!-- YZ String: Used for non-analyzed fields text_ru -->
>   <fieldType name="date" class="solr.TrieDateField" sortMissingLast="true" omitNorms="true"/>
>   <fieldType name="double" class="solr.TrieDoubleField" sortMissingLast="true" omitNorms="true"/>
>   <fieldType name="int" class="solr.TrieIntField" sortMissingLast="true" omitNorms="true"/>
> 
>   <fieldType name="boolean" class="solr.BoolField" sortMissingLast="true" omitNorms="true"/>
>   <fieldType name="_yz_str" class="solr.StrField" sortMissingLast="true" />
>   <fieldtype name="ignored" stored="false" indexed="false" multiValued="true" class="solr.StrField" />
>   <fieldType name="string_ci" class="solr.TextField" sortMissingLast="true" omitNorms="true">
>         <analyzer>
>             <tokenizer class="solr.StandardTokenizerFactory"/>
>             <filter class="solr.LowerCaseFilterFactory" />
>             <filter class='solr.PatternReplaceFilterFactory' pattern='ё' replacement='е' replace='all'/>
>         </analyzer>
>     </fieldType> 
>   </types>
> </schema>
> 
> Best regards,
> Roman
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150312/0d75380a/attachment-0002.html>


More information about the riak-users mailing list