Discrepancies between /stats http endpoint and riak-admin stat show metrics...

Matthew Brender mbrender at basho.com
Thu Mar 26 11:40:23 EDT 2015


Hi John,

I believe I saw this conversation over IRC. Sean responded saying "those
measure at different layers, seems reasonable to me. I mean, your 100% is
bad... but those numbers seem to make sense to me."

Did you end up finding the clarity you need here? It'd be helpful to hear
the details.


*Matt Brender | Developer Advocacy Lead*
Basho Technologies
t: @mjbrender <https://twitter.com/mjbrender>


On Tue, Mar 24, 2015 at 12:36 PM, John O'Brien <boardom at gmail.com> wrote:

> Quick question...
>
> Is it safe to assume these two metrics endpoint are expected to display
> the same stats.
>
> watch -n 1 riak-admin stat show **get_fsm_time**
>
> shows 0's for node_get_fsm_time_99/95  (occasionally will see stats build
> up for them, but then vanish back to 0).
>
> The stats interface via :8098/stats seems to be more reliable, in that I
> never see 0 entries..
>
> This running riak 2.0.5, although I'm pretty sure I recall seeing this on
> previous deployments.
>
> Thanks,
>
> John
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150326/60fa80ba/attachment-0002.html>


More information about the riak-users mailing list