No WM route

Christopher Meiklejohn cmeiklejohn at basho.com
Mon May 4 15:27:41 EDT 2015


> On Apr 23, 2015, at 5:42 PM, Amit Anand <aanand at viimed.com> wrote:
> 
> Hi all Im very new to Riak CS so please bear with me! Finally managed to get Riak, Riak CS and Stanchion all running and now Im trying to add the admin user. When I run my curl command I get nothing back and in the logs I see this error:
> 
> 2015-04-23 11:37:18.024 [error] <0.94.0> No WM route: 'POST' /riak-cs/user {7,{"user-agent",{'User-Agent',"curl/7.29.0"},{"host",{'Host',"10.7.2.113:8080"},{"accept",{'Accept',"*/*"},nil,{"content-type",{'Content-Type',"application/json"},{"content-length",{'Content-Length',"45"},nil,nil},nil}},nil},{"x-rcs-rewrite-path",{"x-rcs-rewrite-path","/riak-cs/user"},{"x-rcs-raw-url",{"x-rcs-raw-url","/riak-cs/user"},nil,nil},nil}}}
> 
> 
> I have set anonymous user to on in the riak-cs.conf AS WELL as to true in the advanced.config. I tried with just in .conf and that didnt work either. Would anybody have any ideas on how to get this work I would really appreciate it. Thanks and sorry if Im asking a basic question I just cant figure it out.

Hi Amit,

Are you making a request to the node running stanchion or the Riak CS node when attempting to add the admin user?

- Chris

Christopher Meiklejohn
Senior Software Engineer
Basho Technologies, Inc.
cmeiklejohn at basho.com





More information about the riak-users mailing list