No WM route

Charlie Voiselle cvoiselle at basho.com
Tue May 12 11:08:39 EDT 2015


This error is usually caused when `admin.listener` is configured in
riak-cs.conf.  Either remove that line from the configuration file, or use
that IP and port for your create user request.

Please let me know if that helps you out

Charlie Voiselle
Basho Client Services
On Apr 23, 2015 8:46 AM, "Amit Anand" <aanand at viimed.com> wrote:

> Hi all Im very new to Riak CS so please bear with me! Finally managed to
> get Riak, Riak CS and Stanchion all running and now Im trying to add the
> admin user. When I run my curl command I get nothing back and in the logs I
> see this error:
>
> 2015-04-23 11:37:18.024 [error] <0.94.0> No WM route: 'POST' /riak-cs/user
> {7,{"user-agent",{'User-Agent',"curl/7.29.0"},{"host",{'Host',"
> 10.7.2.113:8080
> "},{"accept",{'Accept',"*/*"},nil,{"content-type",{'Content-Type',"application/json"},{"content-length",{'Content-Length',"45"},nil,nil},nil}},nil},{"x-rcs-rewrite-path",{"x-rcs-rewrite-path","/riak-cs/user"},{"x-rcs-raw-url",{"x-rcs-raw-url","/riak-cs/user"},nil,nil},nil}}}
>
>
> I have set anonymous user to on in the riak-cs.conf AS WELL as to true in
> the advanced.config. I tried with just in .conf and that didnt work either.
> Would anybody have any ideas on how to get this work I would really
> appreciate it. Thanks and sorry if Im asking a basic question I just cant
> figure it out.
>
> Im running CentOS 7 and:
>
> [root at riakcs riak-cs]# riak version
> 2.1.0
> [root at riakcs riak-cs]# riak-cs version
> 2.0.0
> [root at riakcs riak-cs]# stanchion version
> 2.0.0
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150512/d9f6f3a5/attachment-0002.html>


More information about the riak-users mailing list