riak source build error.

Jon Meredith jmeredith at basho.com
Thu May 21 08:19:51 EDT 2015


Hi Atul,

It's probably because it's just a tarball of the git source tree.  It's
easy to generate the autoconf, but would be better if we provided it with
the tarball.  Instructions should be included on how to build in
HOWTO/Install.md, here's the section on how to generate the configure
script (you'll need to export an environment variable ERL_TOP pointing to
the top of the erlang source tree).

### Building in Git ###


When building in a Git working directory you also have to have a GNU
`autoconf`

of at least version 2.59 on your system, because you need to generate the

`configure` scripts before you can start building.


The `configure` scripts are generated by invoking `./otp_build autoconf` in

the `$ERL_TOP` directory. The `configure` scripts also have to be
regenerated

when a `configure.in` or `aclocal.m4` file has been modified. Note that when

checking out a branch a `configure.in` or `aclocal.m4` file may change

content, and you may therefore have to regenerate the `configure` scripts

when checking out a branch. Regenerated `configure` scripts imply that you

have to run `configure` and build again.


> *NOTE*: Running `./otp_build autoconf` is **not** needed when building

> an unmodified version of the released source.


Other useful information can be found at our github wiki:

<http://wiki.github.com/erlang/otp>



On Wed, May 20, 2015 at 11:27 PM, Atul Sowani <sowani at gmail.com> wrote:

> Hi!
>
> While waiting for some help, I wanted to try to compile Riak code with the
> recommended Erlang version R16B02. On my system I had R17. So I downloaded
> Basho's Erlang distribution as described on
> http://docs.basho.com/riak/latest/ops/building/installing/erlang/
>
> One thing I noticed after extracting OTP_R16B02_basho8 is that configure
> script is missing. I generated configure script using autoconf. Is this the
> correct procedure, or the configure script should have been there to start
> with?
>
> After generating configure myself, I executed it. However, it seems that
> it also expects a "configure" script under directory
> OTP_R16B02_basho8/erts/autoconf/configure
>
> This script is missing. My question is should this script get
> auto-generated or am I supposed to generate one? If it is supposed to get
> auto-generated, for some reason it is not getting generated.
>
> Has anybody faced these problems earlier? Am I doing the right thing or
> missing something important?
>
> Thanks,
> Atul.
>
> On Wed, May 20, 2015 at 11:49 AM, Atul Sowani <sowani at gmail.com> wrote:
>
>> Hi Clay and Rob,
>>
>> Thank for responding to my query. Rob, sorry for combining reply for
>> your mail here but I guess following information will be useful for both of
>> you.
>>
>> My current interaction with Riak is only for evaluation and to see how
>> easy/difficult it is to use it for different Linux distributions. Hence I
>> obtained the Riak source code from GitHub and tried to compile it. I am no
>> expert in Erlang and have never used it before. So I am worried about the
>> error I got while compiling Riak. I tried to search for similar error on
>> Google, but it did not lead me to any definitive solution. I am using
>> Erlang 17.1 version.
>>
>> Thanks,
>> Atul.
>>
>>
>>
>> On Tue, May 19, 2015 at 6:29 PM, Clay Price <cprice at basho.com> wrote:
>>
>>> Hey Atul,
>>>
>>> I'd like to connect you with one of our solutions architects, who should
>>> be able to help with your issue. Do you have some availability on Thursday
>>> to discuss your issue? Also, if you could send over to me your use case for
>>> Riak, I can get some information prepared that you might find beneficial.
>>>
>>> Looking forward to hearing back.
>>>
>>> Clay
>>>
>>> On Tue, May 19, 2015 at 7:23 AM, Atul Sowani <sowani at gmail.com> wrote:
>>>
>>>> Hi,
>>>>
>>>> I am new to this mailing list. I am trying to build riak from source on
>>>> Ubuntu 14.10. I cloned riak code from GitHub and as given in "Building
>>>> Riak" section of README.org file, issued "make rel" command. Everything
>>>> seemed to compile fine, until I received following error as in the log
>>>> snippet below:
>>>>
>>>> ==> riak (compile)
>>>> ./rebar generate
>>>> ==> rel (generate)
>>>> ERROR: Unable to generate spec: read file info
>>>> /usr/lib/erlang/man/man1/gem.1.gz failed
>>>> ERROR: Unexpected error: rebar_abort
>>>> ERROR: generate failed while processing /home/test/riak/rel: rebar_abort
>>>> Makefile:34: recipe for target 'generate' failed
>>>> make: *** [generate] Error 1
>>>>
>>>> /usr/lib/erlang/man/man1/gem.1.gz file is present and is a valid file
>>>> (meaning not an empty file, inaccessible file etc.)
>>>>
>>>> I have no idea how to get around this error. Any help is highly
>>>> appreciated.
>>>>
>>>> Thanks,
>>>> Atul.
>>>>
>>>> _______________________________________________
>>>> riak-users mailing list
>>>> riak-users at lists.basho.com
>>>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>>
>>>>
>>>
>>>
>>> --
>>> Clay Price
>>> 571-732-2502
>>> www.basho.com
>>>
>>
>>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>


-- 
Jon Meredith
Chief Architect
Basho Technologies, Inc.
jmeredith at basho.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20150521/ae068515/attachment-0002.html>


More information about the riak-users mailing list