Unable to create anonymous user

Dmitri Zagidulin dzagidulin at basho.com
Wed Nov 25 10:04:40 EST 2015


Hi Ben,

Just to double-check:
1) is Stanchion installed and running, when you try to create the user?
(and the stanchion_host entry is pointing to it, in cs config?)

2) is anonymous_user_creation = on in the config file?

3) do you have 'buckets.default.allow_mult = true' in the Riak config file?

4) (this is likely to be yes, but just to check) Have you restarted Riak
since configuring the advanced.config backend?

Dmitri

On Tue, Nov 24, 2015 at 6:40 PM, Ben Rudolph <brudolph at dimagi.com> wrote:

> Hi,
>
> I've almost completed the cluster setup but am running into issues with
> anonymous user creation. All machines ping/pong and their IPs are matching.
> When I run the curl command to create an anonymous user:
>
> curl -H 'Content-Type: application/json' -XPOST http://**:8080/riak-cs/user
> --data '{"email":"email at email.com", "name":"admin_user"}'
>
> And I get an XML response that says Internal Server Error. The console.log
> file looks like this:
>
> 2015-11-24 23:16:35.572 [error] <0.439.0> Webmachine error at path
> "/riak-cs/user" :
> {error,{error,{badmatch,{error,malformed_xml}},[{riak_cs_s3_response,xml_error_code,1,[{file,"src/riak_cs_s3_response.erl"},{line,335}]},{riak_cs_s3_response,error_response,1,[{file,"src/riak_cs_s3_response.erl"},{line,249}]},{riak_cs_wm_user,accept_json,2,[{file,"src/riak_cs_wm_user.erl"},{line,119}]},{webmachine_resource,resource_call,3,[{file,"src/webmachine_resource.erl"},{line,186}]},{webmachine_resource,do,3,[{file,"src/webmachine_resource.erl"},{line,142}]},{webmachine_decision_core,resource_call,...},...]}}
> in riak_cs_s3_response:xml_error_code/1 line 335
>
> Which led me to this issue here
> <https://github.com/basho/riak_cs/issues/970>. However my advanced.config
> already looks like this (which is what is suggested in the issue):
> [
>  {riak_kv, [
>               {add_paths, ["/usr/lib/riak-cs/lib/riak_cs-2.0.1/ebin"]},
>               {storage_backend, riak_cs_kv_multi_backend},
>               {multi_backend_prefix_list, [{<<"0b:">>, be_blocks}]},
>               {multi_backend_default, be_default},
>               {multi_backend, [
>                   {be_default, riak_kv_eleveldb_backend, [
>                       {total_leveldb_mem_percent, 30},
>                       {data_root, "/opt/data/riak/leveldb"}
>                   ]},
>                   {be_blocks, riak_kv_bitcask_backend, [
>                       {data_root, "/opt/data/riak/bitcask"}
>                   ]}
>               ]}
>   ]}
> ].
>
> Any insight would be useful!
>
> Thanks,
> Ben
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20151125/87836cff/attachment-0002.html>


More information about the riak-users mailing list