Yokozuna indexes too slow

ilyas i.sergeev at keepsolid.com
Thu Oct 1 10:34:05 EDT 2015



> Hello Ilyas, I’ve got a few questions for you to help diagnose the 
> performance problem.
>
Hi and thank you for the answer

> * What Riak version are you running?
2.1.1 from debian package
>
> * Are you using the default solrconfig on the index, or a custom 
> configuration?
default solrconfig
>
> * You say that there is a 200x slow down when Yokozuna indexing is 
> enabled. Do you have any specific numbers? A graph would be helpful if 
> you can generate one.
about 50 put operations per second to bucket with solr indexes, about 
1000 put operations per second to bucket without indexes
>
> * When you say that Yokozuna takes up 100% of one core, have you been 
> able to narrow that down to specific process within Yokozuna or Riak? 
> Using “riak-admin top” might help here.


Load:  cpu         1               Memory:  total      166760 
binary      16351
procs    1199                        processes  105055 code        16407
runq        0                        atom          687 ets          7961

Pid                 Name or Initial Func         Time Reds     
Memory       MsgQ Current Function
-------------------------------------------------------------------------------------------------------------------------------
<6420.625.0>        yz_cover                      '-' 398302      
34320          0 gen_server:loop/6
<6420.25.0>         code_server                   '-' 128520     
230360          0 code_server:loop/1
<6420.242.0>        riak_ensemble_storage         '-' 47481       
3848          0 gen_server:loop/6
<6420.244.0>        riak_ensemble_manager         '-' 41886     
612216          0 gen_server:loop/6
<6420.852.0>        riak_core_vnode:init/1        '-' 5772      
35016          0 gen:do_call/4
<6420.847.0>        riak_core_vnode:init/1        '-' 5440      
55712          0 gen:do_call/4
<6420.96.0>         riak_sysmon_filter            '-' 4228       
8776          0 gen_server:loop/6
<6420.24.0>         file_server_2                 '-' 2899       
2744          0 gen_server:loop/6
<6420.107.0>        erlang:apply/2                '-' 2351       
2600          0 cpu_sup:measurement_server_loop/1
<6420.1298.0>       riak_ensemble_peer:init/1     '-' 1905       
9344          0 gen_fsm:loop/7
>
> * Can you provide your JVM configuration (heap settings, etc.)?

-server -d64 -Xms2g -Xmx4g -XX:+UseStringCache 
-XX:+UseCompressedOopsriak-users mailing list



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20151001/26525824/attachment-0002.html>


More information about the riak-users mailing list