adding auth user not valid

Outback Dingo outbackdingo at gmail.com
Fri Oct 2 23:28:34 EDT 2015


On Tue, Sep 29, 2015 at 11:01 AM, Shunichi Shinohara <shino at basho.com>
wrote:

> Hi Outback,
>
> Sorry for very late response.
> It seems that riak-cs doesn't/can't communicate with stanchion node.
> There are a couple of possible reasons:
>
> - admin.key and admin.secret should be set both in riak-cs and stanchion
> - stanchion_host should be set properly as stanchion node's listen
> configuration
> - servers that riak-cs node and stanchion nodes are running should be
>   communicate by TCP.
>
> I think packet capture (by tcpdump or wireshark or...) is useful to
> investigate the communication between riak-cs and stanchion.
>
> Thanks,
> Shino
>


more like ENOTENOUGHNODES..... pretty perplexing to chase down when you
think somethings running and its not....
anyway i got it sorted out thanks,.



>
> 2015-09-15 13:21 GMT+09:00 Outback Dingo <outbackdingo at gmail.com>:
> > seems the docs with auth creds is invalid... or im still broken...
> >
> >
> >
> > curl -XPOST http://localhost:8080/riak-cs/user \
> >   -H 'Content-Type: application/json' \
> >   -d '{"email":"admin at admin.com", "name":"admin"}'
> >
> >
> > returns
> >
> > curl -H 'Content-Type: application/json' -X POST
> > http://localhost:8080/riak-cs/user --data '{"email":"admin at admin.com",
> > "name":"admin"}'
> >
> > <html><head><title>500 Internal Server
> > Error</title></head><body><h1>Internal Server Error</h1>The server
> > encountered an error while processing this
> > request</body></html>root at vmbsd:/usr/local/etc/riak-cs #
> >
> > and the log shows
> > 2015-09-15 14:20:33.678 [error] <0.9846.4> Webmachine error at path
> > "/riak-cs/user" :
> >
> {error,{error,{badmatch,{error,malformed_xml}},[{riak_cs_s3_response,xml_error_code,1,[{file,"src/riak_cs_s3_response.erl"},{line,335}]},{riak_cs_s3_r
> >
> esponse,error_response,1,[{file,"src/riak_cs_s3_response.erl"},{line,249}]},{riak_cs_wm_user,accept_json,2,[{file,"src/riak_cs_wm_user.erl"},{line,119}]},{webmachine_resource,resource_call,3,[{file,"src/webmachine_resource.erl"},{line,1
> >
> 86}]},{webmachine_resource,do,3,[{file,"src/webmachine_resource.erl"},{line,142}]},{webmachine_decision_core,resource_call,...},...]}}
> > in riak_cs_s3_response:xml_error_code/1 line 335
> >
> >
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20151003/09af61c8/attachment-0002.html>


More information about the riak-users mailing list