how to determine riak version

David Byron dbyron at dbyron.com
Fri Apr 22 15:08:01 EDT 2016


Thanks for the confirmation.

-DB

On 4/22/16 12:06 PM, Douglas Rohrer wrote:
> David:
>
> riak_kv is actually a (semi)independent library we incorporate (along with many others) into Riak, the product. There are times where riak_kv, the library, is actually not versioned when we release a new Riak, so those two version numbers are not necessarily going to always be the same.
>
> Doug Rohrer
>
>> On Apr 22, 2016, at 2:28 PM, David Byron <dbyron at dbyron.com> wrote:
>>
>> I'm pondering upgrading riak from 2.1.3 to 2.1.4 and got myself confused confirming that I really am running 2.1.3 at the moment.
>>
>> I installed riak from here: https://packagecloud.io/basho/riak/packages/ubuntu/trusty/riak_2.1.3-1_amd64.deb.
>>
>> and all of this looks promising:
>>
>> $ riak version
>> 2.1.3
>>
>> $ ls /usr/lib/riak/releases/
>> 2.1.3  RELEASES  start_erl.data
>>
>> $ dpkg -l | grep riak
>> ii  riak 2.1.3-1      amd64        Riak is a distributed data store
>>
>> but then there's also this:
>>
>> $ sudo riak-admin status | grep riak_kv_version
>> riak_kv_version : <<"2.1.2-0-gf969bba">>
>>
>> I really wanted riak_kv_version to say 2.1.3-<something>.
>>
>> I'm clearly paranoid, but can someone help me feel better about this?
>>
>> Thanks much.
>>
>> -DB




More information about the riak-users mailing list