Riak S2 error

Charlie Voiselle cvoiselle at basho.com
Thu Jan 7 18:12:00 EST 2016


Michael:

If that is the entire contents of your advanced.config file, you will need to wrap all of that in an erlang list delimiter. [].  For example

[
{riak_kv, [
    {add_paths, "/usr/lib64/riak-cs/lib/riak_cs-2.1.0/ebin"},
    {storage_backend, riak_cs_kv_multi_backend},
    {multi_backend_prefix_list, [{<<"0b:">>, be_blocks}]},
    {multi_backend_default, be_default},
    {multi_backend, [
        {be_default, riak_kv_eleveldb_backend, [
            {total_leveldb_mem_percent, 30},
            {data_root, "/var/lib/riak/leveldb"}
        ]},
        {be_blocks, riak_kv_bitcask_backend, [
            {data_root, "/var/lib/riak/bitcask"}
        ]}
    ]}
]}
].


Give that a shot and let us know if it works for you!

Thanks,
Charlie Voiselle

> On Jan 7, 2016, at 11:53 AM, Michael Walsh <mike at walshnetwork.com> wrote:
> 
> Sure thing.
> 
> And thanks!
> 
> 
> advanced.config:
> {riak_kv, [
>     {add_paths, "/usr/lib64/riak-cs/lib/riak_cs-2.1.0/ebin"},
>     {storage_backend, riak_cs_kv_multi_backend},
>     {multi_backend_prefix_list, [{<<"0b:">>, be_blocks}]},
>     {multi_backend_default, be_default},
>     {multi_backend, [
>         {be_default, riak_kv_eleveldb_backend, [
>             {total_leveldb_mem_percent, 30},
>             {data_root, "/var/lib/riak/leveldb"}
>         ]},
>         {be_blocks, riak_kv_bitcask_backend, [
>             {data_root, "/var/lib/riak/bitcask"}
>         ]}
>     ]}
> ]}.
> 
> On Wed, Jan 6, 2016 at 5:44 PM, Shunichi Shinohara <shino at basho.com <mailto:shino at basho.com>> wrote:
> Hi Michael,
> 
> Could you provide all the result of "riak config generate -l debug" as well as
> riak.conf and advanced.config?
> 
> Thanks,
> Shino
> 
> 2016-01-07 9:05 GMT+09:00 Michael Walsh <mike at walshnetwork.com <mailto:mike at walshnetwork.com>>:
> > All,
> >
> > I'm trying to set up a RIak S2 instance to integrate with KV and I'm getting
> > the following cuttlefish error out of advanced.config. Any suggestions on
> > where I'm going wrong?
> >
> > notes: erlang error was fixed. All paths are correct.
> >
> > Thanks!
> >
> > -Michael Walsh
> >
> > $riak config generate -l debug
> >
> > ...
> >                              {riak_kv,
> >                               [{add_paths,
> >
> > "/usr/lib64/riak-cs/lib/riak_cs-2.1.0/ebin"},
> >                                {storage_backend,riak_cs_kv_multi_backend},
> >                                {multi_backend_prefix_list,
> >                                 [{<<"0b:">>,be_blocks}]},
> >                                {multi_backend_default,be_default},
> >                                {multi_backend,
> >                                 [{be_default,riak_kv_eleveldb_backend,
> >                                   [{total_leveldb_mem_percent,30},
> >                                    {data_root,"/var/lib/riak/leveldb"}]},
> >                                  {be_blocks,riak_kv_bitcask_backend,
> >
> > [{data_root,"/var/lib/riak/bitcask"}]}]}]}) (lists.erl, line 1247)
> >   in function  cuttlefish_escript:engage_cuttlefish/1
> > (src/cuttlefish_escript.erl, line 375)
> >   in call from cuttlefish_escript:generate/1 (src/cuttlefish_escript.erl,
> > line 258)
> >   in call from escript:run/2 (escript.erl, line 747)
> >   in call from escript:start/1 (escript.erl, line 277)
> >   in call from init:start_it/1
> >   in call from init:start_em/1
> >
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com <mailto:riak-users at lists.basho.com>
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com <http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com>
> >
> 
> <riak.conf><riak_config_gen>_______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com <mailto:riak-users at lists.basho.com>
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com <http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20160107/e1c2b22a/attachment-0002.html>


More information about the riak-users mailing list