Riak versioning and handoff bug in 2.1.0

Vladyslav Zakhozhai v.zakhozhai at smartweb.com.ua
Wed Jan 13 03:28:45 EST 2016


Hi,

According to the following link there is a bug in 2.1.0 which may cause
data loss:
https://docs.basho.com/riak/2.0.5/community/product-advisories/210-dataloss/

I've installed 2.1.1 riak deb package from basho's repository on
packagecloud. But from riak stats I see that there is riak_core_version
2.1.1 in that package but riak_kv - 2.1.0. I think that this version of
package is affected by this bug. Am I right?

Is there available compatability list of riak, riak cs and stanchion for
recent versions?
http://docs.basho.com/riakcs/latest/cookbooks/Version-Compatibility/ is
outdated. Can I use basho's package 2.1.3 (riak_core_version: 2.1.5,
riak_kv_version: 2.1.2) with riak cs and stanchion 2.1.0 basho's package?

Thank you in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20160113/01227eaf/attachment-0002.html>


More information about the riak-users mailing list