accessor for FetchDatatype's location?

David Byron dbyron at dbyron.com
Mon Jan 25 13:08:25 EST 2016


Finally got around to this:

https://github.com/basho/riak-java-client/pull/590

Thanks for the help.

-DB

On 1/20/16 7:58 AM, Alex Moore wrote:
> Hey David,
>
> We include/shade that jar in the final riak-client jar so we stopped
> shipping it separately.
> You'll want to clone riak_pb, and build this tag to install it locally
> for dev: https://github.com/basho/riak_pb/tree/java-2.1.1.0
>
> You'll need protocol buffers 2.5.0
> <https://github.com/google/protobuf/releases/tag/v2.5.0> to build, and
> you should be able to build/install the riak_pb lib with `mvn install`.
> If you use homebrew you can use this
> <http://stackoverflow.com/a/23760535> procedure to install the older
> protobuf lib (just swap protobuf241 for protobuf250).
>
> Thanks,
> Alex
>
> On Thu, Jan 14, 2016 at 2:22 PM, David Byron <dbyron at dbyron.com
> <mailto:dbyron at dbyron.com>> wrote:
>
>     On 1/14/16 7:40 AM, Alex Moore wrote:
>     > Hi David,
>     >
>     > It doesn't look like we expose that property anywhere, but it can
>     > probably be chalked up to YAGNI when it was written.   Go forth and
>     > PR :)
>
>     Excellent...except for this at the HEAD of develop (24e1404).
>
>     $ mvn clean install
>     [INFO] Scanning for projects...
>     [INFO]
>     [INFO]
>     ------------------------------------------------------------------------
>     [INFO] Building Riak Client for Java 2.0.5-SNAPSHOT
>     [INFO]
>     ------------------------------------------------------------------------
>     [WARNING] The POM for com.basho.riak.protobuf:riak-pb:jar:2.1.1.0 is
>     missing, no dependency information available
>     [INFO]
>     ------------------------------------------------------------------------
>     [INFO] BUILD FAILURE
>     [INFO]
>     ------------------------------------------------------------------------
>     [INFO] Total time: 0.285 s
>     [INFO] Finished at: 2016-01-14T11:17:22-08:00
>     [INFO] Final Memory: 10M/309M
>     [INFO]
>     ------------------------------------------------------------------------
>     [ERROR] Failed to execute goal on project riak-client: Could not
>     resolve dependencies for project
>     com.basho.riak:riak-client:jar:2.0.5-SNAPSHOT: Failure to find
>     com.basho.riak.protobuf:riak-pb:jar:2.1.1.0 in
>     https://repo.maven.apache.org/maven2 was cached in the local
>     repository, resolution will not be reattempted until the update
>     interval of central has elapsed or updates are forced -> [Help 1]
>
>     The latest version I see at
>     http://mvnrepository.com/artifact/com.basho.riak.protobuf/riak-pb is
>     2.0.0.16.  When I change pom.xml to use that version I get
>     truckloads of errors.
>
>     -DB




More information about the riak-users mailing list