Riak Search 2.0 - CRDT Sets within Maps not returned in search results

Weixi Yen weixi at spacechatapp.com
Wed Jan 27 14:47:10 EST 2016


Awesome, that's what I was looking for, thank you!

On Wed, Jan 27, 2016 at 11:40 AM, Zeeshan Lakhani <zlakhani at basho.com>
wrote:

> Weixi,
>
> Are you using 2.0.0 or another 2.0.* version?
>
> If you look at
> https://github.com/basho/yokozuna/blob/2.0.0/priv/default_schema.xml#L104,
> sets are not stored in the default schema, as they can get large. They’re
> indexed for search, but will not return in the result-set. In 2.0.7 and in
> 2.1.3, the default schema was changed to store them. If you modify the
> existing default schema you have (stored=true), reload the schema, and
> reindex, you’ll see the results.
>
> Thanks.
>
> Zeeshan Lakhani
> programmer |
> software engineer at @basho |
> org. member/founder of @papers_we_love | paperswelove.org
> twitter => @zeeshanlakhani
>
> On Jan 27, 2016, at 2:34 PM, Weixi Yen <weixi at spacechatapp.com> wrote:
>
> I have a CRDT Map bucket that I'm running searches on in Yokozuna (using
> _yz_default index for now)
>
> However, the search results do not return any fields of the map that are
> CRDT sets.  Is this intended behavior?
>
> Thanks in advance!
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20160127/896788ca/attachment-0002.html>


More information about the riak-users mailing list