Continuous HTTP POSTs to Riak

Qiang Cao caoqiang.cs at gmail.com
Thu Mar 3 21:31:59 EST 2016


Thanks, Christopher! I played with n_val, r and w on a bucket-type level
for a while. No luck even I set r equal to n_val (r+w>n_val).

Qiang

On Thu, Mar 3, 2016 at 9:25 PM, Christopher Mancini <cmancini at basho.com>
wrote:

> If you don't need strong consistency for all Riak requests, just certain
> ones, then explore the use of R and N vals that can be passed along with
> the request or on a bucket-type level.
>
> On Thu, Mar 3, 2016 at 9:23 PM Mark Schmidt <mschmidt at orcawave.net> wrote:
>
>> Hi Qiang,
>>
>>
>>
>> Other more skilled folks can correct me if I am wrong, but I believe you
>> can enforce strong consistency on your nodes:
>> http://docs.basho.com/riak/latest/theory/concepts/strong-consistency/
>>
>>
>>
>> If I recall, you will take a performance hit as all nodes must receive
>> the data.
>>
>>
>>
>> Thanks,
>>
>>
>>
>> -          Mark Schmidt
>>
>>
>>
>> *From:* riak-users [mailto:riak-users-bounces at lists.basho.com] *On
>> Behalf Of *Qiang Cao
>> *Sent:* Thursday, March 03, 2016 6:13 PM
>> *To:* Dave King <djking at gmail.com>
>> *Cc:* riak-users <riak-users at lists.basho.com>
>> *Subject:* Re: Continuous HTTP POSTs to Riak
>>
>>
>>
>> Thanks, Dave! I'm aware of Riak's eventual consistency. I wonder how I
>> can get Riak work in the way as I need. I'm in a situation where I expect
>> the immediate GET reads the value I've just posted. And the GET request
>> isn't sent out until the POST is done.
>>
>>
>>
>> Thanks,
>>
>> -Qiang
>>
>>
>>
>> On Thu, Mar 3, 2016 at 6:53 PM, Dave King <djking at gmail.com> wrote:
>>
>> You need to google 'Eventual consistency'.
>>
>>
>>
>> - Peace
>>
>> Dave
>>
>>
>>
>>
>>
>> On Thu, Mar 3, 2016 at 4:23 PM, Qiang Cao <caoqiang.cs at gmail.com> wrote:
>>
>> Hi All,
>>
>>
>>
>> I use Riak as a KV store and send http requests to its REST API to update
>> entries. Instead of using curl, I use Apache HttpClient to send requests.
>>
>>
>>
>> One thing bothering me is that sometimes I find the entry isn't properly
>> updated after an HTTP POST/PUT. For example, if I do an HTTP GET on the
>> same key immediately after an HTTP POST, the chance is good that I get a
>> stale value. This happens when I continuously POST to a multi-node Riak,
>> and some of the posts target the same key.
>>
>>
>>
>> Also, I find I don't have this issue if I use a single-node Riak. So I
>> think something wasn't correct with my multi-node Riak cluster (I set
>> "allow_mult" to false).  Any thoughts?
>>
>>
>>
>> Thanks in advance!
>>
>>
>>
>> Qiang
>>
>>
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>>
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
> --
> Sincerely,
>
> Christopher Mancini
> -----------------------------
>
> employee = {
>     purpose: solve problems with code,
>     phone:    7164625591,
>     email:     cmancini at basho.com,
>     github:    http://www.github.com/christophermancini
> }
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20160303/ecdc58ab/attachment-0002.html>


More information about the riak-users mailing list