ring_creation_size & ring_partition_number error joining 2.1.3 node to 2.1.1 cluster

Robert Latko robert at lmi-global.com
Sun Mar 6 17:10:02 EST 2016


Hi All,

I've got a cluster in 2.1.1 and was wanting to join a 2.1.3 node to it

I am getting the following error:

# ./bin/riak-admin cluster join a-backend at 10.0.0.199
Failed: a-backend at 10.0.0.199 has a different ring_creation_size

So... for the new 2.1.3
# ./bin/riak-admin status | grep ring
ring_creation_size : 256
ring_members : ['node-template at 10.0.0.54']
*ring_num_partitions : 256*
ring_ownership : <<"[{'node-template at 10.0.0.54',256}]">>
rings_reconciled : 0
rings_reconciled_total : 0

AND for node a-backend at 10.0.0.199
# ./bin/riak-admin status | grep ring
ring_creation_size : 256
ring_members : ['a-backend at 10.0.0.199','b-backend at 10.0.0.200',
*ring_num_partitions : 64*
ring_ownership : <<"[{'b-backend at 10.0.0.200',13},\n 
{'c-backend at 10.0.0.201',13},\n {'d-backend at 10.0.0.202',13},\n 
{'e-backend at 10.0.0.203',12},\n {'a-backend at 10.0.0.199',13}]">>
rings_reconciled : 0
rings_reconciled_total : 32

The 'ring_num_partitions' are different which leaves me to believe this 
is the cause.

A.) How do I increase the 'ring_num_partitions' to 256 in the 2.1.1 
cluster  **OR**
B.) How do I decrease the 'ring_num_partitions' to 64 in the 2.1.3 node?

Any ideas? recommendations?


Thanks in advance,


Robert







-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20160306/65925710/attachment-0002.html>


More information about the riak-users mailing list