Using $bucket index for listing keys

Oleksiy Krivoshey oleksiyk at gmail.com
Fri Mar 11 11:52:19 EST 2016


Because otherwise I have no ways to walk all the keys in some of my largest
buckets, paginated query not supported, RpbListKeysReq fails with Riak
'timeout' error. All hopes for Yokozuna then!

On 11 March 2016 at 18:49, Oleksiy Krivoshey <oleksiyk at gmail.com> wrote:

> Hi Magnus,
>
> Yes, thank you. Though I'm stuck a bit. When I experienced recursive
> behaviour with paginated $bucket query I tried to create Yokozuna Solr
> index with an empty schema (just _yz_* fields). Unfortunately querying
> Yokozuna gives me inconsistent number of results as described in my another
> email in this mailing list. Hopefully it will be solved as well :)
>
> On 11 March 2016 at 18:44, Magnus Kessler <mkessler at basho.com> wrote:
>
>> Hi Oleksiy,
>>
>> As Russel pointed out, 2i queries, including $bucket queries, are only
>> supported when the backend supports ordered keys. This is currently not the
>> case with bitcask.
>>
>> It appears, though, that you have discovered a bug where the
>> multi-backend module accepts the query despite the fact that the actually
>> configured backend for the bucket(-type) cannot support the query. I'll
>> make the engineering team aware of this.
>>
>> At this point in time I can only recommend that you do not use the
>> $bucket query with your configuration and use an alternative, such as
>> Solr-based search instead.
>>
>> Kind Regards,
>>
>> Magnus
>>
>> --
>> Magnus Kessler
>> Client Services Engineer
>> Basho Technologies Limited
>>
>> Registered Office - 8 Lincoln’s Inn Fields London WC2A 3BP Reg 07970431
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20160311/bee4fddf/attachment-0002.html>


More information about the riak-users mailing list