Riak-CS False 503 Service Unavailable Error on Client

Luke Bakken lbakken at basho.com
Mon Nov 14 11:41:08 EST 2016


Hi Anthony,

Looking at the linked issue it appears that the 503 response can be
returned erroneously when communication between a Riak CS and Riak
node has an error ("If the first member of the preflist is down").

Is there anything predictable about these errors? You say they come
from 1 client only?
--
Luke Bakken
Engineer
lbakken at basho.com


On Tue, Nov 1, 2016 at 7:51 AM, Valenti, Anthony
<Anthony.Valenti at inmar.com> wrote:
> We are having a lot of 503 Service Unvailable errors for 1 particular
> application client(s) when connecting to Riak-CS.  Everything looks fine in
> Riak/Riak-CS and when I check the Riak-CS access logs, I can see access from
> other applications to other buckets before, during and after the reported
> error time.  We have a 5 node cluster that are load balanced and all of them
> seem to be operating normally and they should be able to handle the incoming
> connections.  We did find this Jira in Github which looks like our exact
> problem (https://github.com/basho/riak_cs/issues/1283) , but there is 1
> comment and it was closed and I’m not sure of the fix/workaround/resolution.
> Has this been resolved in a later version than we are using – riak cs
> 1.5.3-1?  Is there a way to correct the issue from the client side?
>
>
>
> Thanks,
>
> Anthony
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>




More information about the riak-users mailing list