Joining node answers to requests

Guillaume Boddaert guillaume at lighthouse-analytics.co
Tue Sep 20 08:54:15 EDT 2016


Well, I guess that's on me. Solr is unable to create my index due to an 
extension I'm using, thus Riak-4 don't know a working index for the 
bucket-type.

Guillaume

On 20/09/2016 14:48, Guillaume Boddaert wrote:
> Hi,
>
> I'm currently adding two new node to my production. Yet, they seems to 
> answer my requests while joining. I have strange answers with bad prop 
> types for my bucket (index_name in my case).
>
> admin at riak-1:~$ sudo riak-admin member-status
> ================================= Membership 
> ==================================
> Status     Ring    Pending    Node
> ------------------------------------------------------------------------------- 
>
> joining     0.0%      --      'riak at riak-4.riak.wisel.io'
> joining     0.0%      --      'riak at riak-5.riak.wisel.io'
> valid      32.8%      --      'riak at riak-1.riak.wisel.io'
> valid      34.4%      --      'riak at riak-2.riak.wisel.io'
> valid      32.8%      --      'riak at riak-3.riak.wisel.io'
> ------------------------------------------------------------------------------- 
>
> Valid:3 / Leaving:0 / Exiting:0 / Joining:2 / Down:0
>
> This is a sample response from python when a ask for properties, 
> index_name is missing and the claimant is riak-4
>
> {'n_val': 2, 'r': 'quorum', 'dw': 'quorum', 'pr': 0, 'claimant': 
> 'riak at riak-4.riak.wisel.io', 'w': 'quorum', 'precommit': [], 
> 'dvv_enabled': True, 'big_vclock': 50, 'last_write_wins': False, 
> 'notfound_ok': True, 'basic_quorum': False, 'linkfun': {'fun': 
> 'mapreduce_linkfun', 'mod': 'riak_kv_wm_link_walker'}, 'pw': 0, 
> 'small_vclock': 50, 'rw': 'quorum', 'young_vclock': 20, 
> 'chash_keyfun': {'fun': 'chash_std_keyfun', 'mod': 'riak_core_util'}, 
> 'allow_mult': True, 'datatype': 'map', 'active': True, 'postcommit': 
> [], 'old_vclock': 86400}
>
> I'm pretty sure I first reached one of my 3 valid nodes for the 
> original query.
> How can I exclude my two joining nodes from serving any response to my 
> clients ?
>
> Guillaume
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com





More information about the riak-users mailing list