Unsolved problem using Riak TS Java Client

Allexandre Sampaio allexandresss at gmail.com
Wed Apr 12 15:12:09 EDT 2017


Hey, now I found the problem. Actually, I was setting up the connection
wrong (forgot to check the default way in the library's page).
Now it's working fine! Thank you for being helpful!

Att.,

*Allexandre Sampaio*
*Sistemas de Informação - IFBA*
*Vitória da Conquista - BA*
*(77) 99964 3521*

2017-04-12 11:40 GMT-03:00 Allexandre Sampaio <allexandresss at gmail.com>:

> Hey Alex, thank you for helping.
> So, answering you:
>
> 1. I'm setting up the connections as recomended in the client's example
> provided by the Docs page, here
> <http://docs.basho.com/riak/ts/1.5.2/developing/java/>. If you prefer,
> you can see my application coding (in progress) on its repository
> <https://github.com/allexandresampaio/inobench/blob/master/Inobench/src/riakts/RiaktsFacade.java> in
> Github.
> 2. Yes, I've already used the riak_shell and the HTTP interface, both work
> fine...
> 3. No, let's say I'm in a hurry and couldn't code the logging module of my
> application until now.
>
> Thank you again!
>
> Att.,
>
> *Allexandre Sampaio*
> *Sistemas de Informação - IFBA*
> *Vitória da Conquista - BA*
> *(77) 99964 3521*
>
> 2017-04-12 11:02 GMT-03:00 Alex Moore <amoore at basho.com>:
>
>> Hi Allexandre,
>>
>> A few things to start:
>>
>> 1. Could you share how you are setting up the connections in the Java
>> client?
>> 2. Are you able to connect to your Riak TS cluster using the HTTP
>> interface, or riak_shell ?
>> 3. Are there any log files from your java application?
>>
>> Thanks,
>> Alex Moore
>> Team Lead, Clients Team
>>
>> On Wed, Apr 12, 2017 at 8:11 AM, Allexandre Sampaio <
>> allexandresss at gmail.com> wrote:
>>
>>> Hi, I'm new to Riak and I'm using the TS version to perform some tests
>>> in my Java application, running on an Ubuntu 16.04 server, for a college
>>> project.
>>> The library I'm using is riak-client-2.1.1, with all of its dependencies.
>>> But, when I try to connect to the DB to save data, the connection
>>> doesn't happen, and after a few minutes, the java proccess is closed.
>>> What could it be? Maybe a problem with the DB settings?
>>>
>>> Att.,
>>>
>>> *Allexandre Sampaio*
>>> *Vitória da Conquista - BA, Brazil*
>>> *+55 (77) 99964 3521 <+55%2077%2099964-3521>*
>>>
>>> _______________________________________________
>>> riak-users mailing list
>>> riak-users at lists.basho.com
>>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>
>>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20170412/ed8337cf/attachment-0002.html>


More information about the riak-users mailing list