riak_repl integration

Russell Brown russell.brown at icloud.com
Tue Dec 5 12:10:39 EST 2017


Hi Raghu,
At present Riak is still stuck on the r16 basho OTP. This will change next year. For now, and the next release of riak, r16 is the compiler you need.

If you want to use riak_repl with open source riak, there are a couple of options. There is the 2.2.4 tag in the basho riak repo, which bet365 kindly put together when riak_repl was open sourced. Cloning https://github.com/basho/riak and checking out tag 2.2.4, then running `make rel` will get you a local release of OS riak as it was at 2.2.3 + riak_repl. Someone did mention maybe building packages of 2.2.4, if you’d rather download than build your own, but I don’t know if that happened yet.

In order to _use_ MDC you can follow the docs on basho’s site http://docs.basho.com/riak/kv/2.2.3/configuring/v3-multi-datacenter/.

There is a branch develop-2.2.5 which is the active work for the next release of riak, which will contain riak_repl.  We plan to release riak-2.2.5 (OS riak+repl, and some small features+bug fixes) in early 2018.

Hope that helps

Cheers

Russell


On 5 Dec 2017, at 16:11, Raghavendra Sayana <raghavendra.sayana.tzzh at statefarm.com> wrote:

> Hi All,
>  
> I want to use riak MDC replication using riak_repl module. Is there any documentation on how I can perform this integration? Do you know what erlang compiler version I should be using to compile the code? Any help on this is appreciated.
>  
> Thanks
> Raghu
>  
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com





More information about the riak-users mailing list