Node is not running!

Magnus Kessler mkessler at basho.com
Wed Feb 22 10:43:53 EST 2017


On 22 February 2017 at 10:34, Jurgen Ramaliu <jurgenramaliu at gmail.com>
wrote:

> Hello RIAK,
>
> I have one problem with riak node configuration. I have install RIAK KV
> and everything is ok.
> I run *riak start* on my CentOS 6.5 and it starts ok.
> I have configure file */etc/hosts* :
>
> *127.0.0.1   localhost localhost.localdomain localhost4
> localhost4.localdomain4*
> *::1         localhost localhost.localdomain localhost6
> localhost6.localdomain6*
> *192.168.1.10          riak1.mydomain.com <http://riak1.mydomain.com/>
>    riak1*
>
> and this file */etc/sysconfig/network* :
>
> *NETWORKING=yes*
> *HOSTNAME=riak1.mydomain.com <http://riak1.mydomain.com/>*
>
> But, when i try to do this steps, on this link :
> http://docs.basho.com/riak/kv/2.2.0/using/running-a-
> cluster/#configure-the-first-node
>
> to configure first node, when I change nodename form :
> *nodename = riak at 127.0.0.1 <riak at 127.0.0.1>* to *nodename
> = riak at 192.168.1.10 <riak at 192.168.1.10>* , riak doesn't start, I take
> back this error messages :
>
> [root at riak1 ~]# riak start
> Node 'riak at 192.168.1.10' not responding to pings.
> Node 'riak at 192.168.1.10' not responding to pings.
> Node is not running!
>
>
>
> or *nodename = riak at riak1.mydomain.com <riak at riak1.mydomain.com>*, riak
> doesn't start, I take back this error messages :
>
> [root at riak1 ~]# riak start
>
> Node 'riak at riak1.mydomain.com' not responding to pings.
> Node 'riak at riak1.mydomain.com' not responding to pings.
> Node is not running!
>
> Can you please tell me how can I resolve this problem?
>
> Thank you in advance,
>
> Jurgen
>
>
Hi Jurgen,

When a node is started for the first time, its name is recorded in the ring
file (a file under /var/lib/riak/ring by default on CentOS). For a single
node that hasn't joined a cluster, yet, the easiest way to start the node
with a new node name is to simply remove the ring directory and then start
the node. Please note that any changes to bucket properties for buckets
under the default bucket type get lost in this process. If any such changes
have been made, re-apply them once the node has been restarted.

Kind Regards,

Magnus

-- 
Magnus Kessler
Client Services Engineer
Basho Technologies Limited

Registered Office - 8 Lincoln’s Inn Fields London WC2A 3BP Reg 07970431
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20170222/03bb3d84/attachment-0002.html>


More information about the riak-users mailing list