Unable to use riak-ts shell

Ricardo Mayerhofer ricardo.ekm at gmail.com
Thu Jan 12 09:36:43 EST 2017


Hi Gordon,
It was a good addition! Very descriptive, you can walk through the
extensions and commands without having to check to the docs. However the
concept of extension is not common and may cause confusion IMO. An option
would be just have it as commands and categories.

Ricardo


On Fri, Jan 6, 2017 at 2:26 PM, Gordon Guthrie <gguthrie at basho.com> wrote:

> Ricardo
>
> There is a comprehensive help facility which you can explore by typing:
> riak-shell>help;
>
> Your feedback on that, and if it is useful would be appreciated…
>
> Gordon
>
> On 6 Jan 2017, at 16:12, Ricardo Mayerhofer <ricardo.ekm at gmail.com> wrote:
>
> That's was it. I had my config file pointing to riak at 127.0.0.1 and
> changed to point to the node name riak at ip-adress. It worked fine.
>
> Thanks.
>
> On Fri, Jan 6, 2017 at 1:01 PM, Brett Hazen <brett at basho.com>wrote:
>
>> Ricardo -
>>
>> What does your riak_shell.config file look like?  How many nodes are in
>> your cluster?  Guessing there might be some hostname resolution issues.
>>
>> Here's the documentation on the config file: http://docs.basho.com/ri
>> ak/ts/1.5.0/using/riakshell/#configuration
>>
>> Cheers,
>> Brett
>>
>> On January 6, 2017 at 6:14:17 AM, Ricardo Mayerhofer (
>> ricardo.ekm at gmail.com) wrote:
>>
>> Hi all,
>> I'm unable to use Riak TS 1.5 shell in Ubuntu 14.04 deploy. When I try to
>> star riak-shell the following messages appear:
>>
>> root at ip-192-168-5-177:/var/lib/riak# riak-shell
>>
>> Erlang R16B02_basho10 (erts-5.10.3) [source] [64-bit] [smp:4:4]
>> [async-threads:10] [hipe] [kernel-poll:false] [frame-pointer]
>>
>> version "riak_shell 1.5/sql compiler 320523031941664944417524937300681317050",
>> use 'quit;' or 'q;' to exit or 'help;' for help
>>
>> Disconnected...
>>
>> riak-shell(1)>CREATE TABLE Expectations
>>
>> riak-shell(1)>(
>>
>> ...
>>
>> riak-shell(1)>);
>>
>> Not connected to riak
>>
>> Riak seems ok:
>>
>> root at ip-192-168-5-177:/var/lib/riak# sudo riak ping
>>
>> pong
>>
>>
>> Any idea of what's going on? Thanks!
>> --
>> Ricardo Mayerhofer
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>
>
> --
> Ricardo Mayerhofer
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
>


-- 
Ricardo Mayerhofer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20170112/51ecb73e/attachment-0002.html>


More information about the riak-users mailing list