Cannot add node to cluster: ring_creation_size

Magnus Kessler mkessler at basho.com
Sat Mar 11 05:12:43 EST 2017


On 8 March 2017 at 19:45, Scites, Troy <Troy_Scites at comcast.com> wrote:

> Hello,
>
> I have 3 nodes in a development environment that were configured in a
> cluster.  It was working fine until one of the servers crashed.  I tried
> clearing the data directory and was able to removed the crashed node from
> the cluster.  When I try to add the third node back in, I get the following
> error:
> Failed: riak@<node> has a different ring_creation_size
>
> All 3 nodes have ring_size set to 64 in the riak.conf.  Has anyone
> experienced this error and have a suggestion for adding the node back into
> the ring?
>
> Thanks,
> Troy
>
>
Hi Troy,

Please check with 'riak status | egrep
"ring_creation_size|ring_num_partitions' what the different nodes believe
to be their actual ring size.

As you have already wiped (some of) the data directory on the crashed node,
you can stop this node and then it's safe to also remove the 'ring'
directory if this node reports a different ring size. Afterwards, restart
the node and attempt to join it to the rest of the cluster.

Please let me know if this solves your issue.

Kind Regards,

Magnus

-- 
Magnus Kessler
Client Services Engineer
Basho Technologies Limited

Registered Office - 8 Lincoln’s Inn Fields London WC2A 3BP Reg 07970431
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20170311/ccb1a0ba/attachment-0002.html>


More information about the riak-users mailing list