Node is not running!

Jurgen Ramaliu jurgenramaliu at gmail.com
Mon Mar 13 05:28:25 EDT 2017


Hello Magnus and Riak Users,

Thanks for your help.
I have another question :

I run command:

*curl -XPUT http://192...:8098/types/default/buckets/test/keys/test
<http://localhost:8098/types/default/buckets/test/keys/test> -H
"Content-Type: text/plain" -d "hello"*

Looks everything is ok , but when I list with command :

*ll /var/lib/riak/bitcask/* , I don't see vnode partitions like this :


|-- 1118962191081472546749696200048404186924073353216-1316787078245894 |
|-- 1316787252.*bitcask.data* | |-- 1316787252.*bitcask.hint* | `--
*bitcask.write.lock*



I see only like this :
*drwxrwxr-x. 2 riak riak 4096 Mar 13 09:58
1004782375664995756265033322492444576013453623296 drwxrwxr-x. 2 riak riak
4096 Mar 13 09:58 1027618338748291114361965898003636498195577569280
drwxrwxr-x. 2 riak riak 4096 Mar 13 09:58
1050454301831586472458898473514828420377701515264 drwxrwxr-x. 2 riak riak
4096 Mar 13 09:58 1073290264914881830555831049026020342559825461248*

Attached is print screen.

Please give me on solution.

Thank you!

Regards,
Jurgen


On Sat, Mar 11, 2017 at 11:51 AM, Magnus Kessler <mkessler at basho.com> wrote:

>
>
> On 8 March 2017 at 08:40, Jurgen Ramaliu <jurgenramaliu at gmail.com> wrote:
>
>> Hello,
>>
>> I have two questions :
>>
>> *1.*
>>
>> Problem with Riak KV installation Bitcask. I try this link to install
>> Bitcask on Riak KV:
>>
>> http://docs.basho.com/riak/kv/2.2.0/setup/planning/backend/bitcask/
>>
>> And when I go on step
>> Bitcask Database Files
>> <http://docs.basho.com/riak/kv/2.2.0/setup/planning/backend/bitcask/#bitcask-database-files>
>>
>> I try to do this command :
>> curl -XPUT http://localhost:8098/types/default/buckets/test/keys/test \
>> -H "Content-Type: text/plain" \ -d "hello
>>
>> I receive this error :
>>
>> *curl: (6) Couldn't resolve host ' -H'*
>> *curl: (6) Couldn't resolve host 'Content-Type: text'*
>> *curl: (6) Couldn't resolve host ' -d'*
>> *curl: (6) Couldn't resolve host 'hello'*
>> *<html><head><title>500 Internal Server
>> Error</title></head><body><h1>Internal Server Error</h1>The server
>> encountered an error while processing this
>> request:<br><pre>{error,function_clause}</pre><P><HR><ADDRESS>mochiweb+webmachine
>> web server</ADDRESS></body></html>*
>>
>
>
> Hi Jurgen,
>
> I am not sure what causes this issue on your machine, but it may be due to
> a copy and paste error. Please try putting the entire command onto one line
> in the shell, like this:
>
> curl -XPUT http://localhost:8098/types/default/buckets/test/keys/test -H
> "Content-Type: text/plain" -d "hello"
>
>
>
>>
>>
>> *2.*
>>
>> Activation bucket type problem.
>> I have create bucket-type hello and i can't activte it.
>> When I try to activate it with command :* riak-admin bucket-type
>> activate hello* , I receive this message : '*hello has been created but
>> cannot be activated yet'*
>>
>>
>>
>> Attached are screen shots.
>> Can you please give to me one solution to resolve those problems?
>>
>
> Please ensure that all nodes in the cluster are up. Before a bucket type
> can be activated, it must have been distributed to all nodes.
>
> Kind Regards,
>
> Magnus
>
>
> --
> Magnus Kessler
> Client Services Engineer
> Basho Technologies Limited
>
> Registered Office - 8 Lincoln’s Inn Fields London WC2A 3BP Reg 07970431
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20170313/258a887e/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: riak bitcask.png
Type: image/png
Size: 114576 bytes
Desc: not available
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20170313/258a887e/attachment.png>


More information about the riak-users mailing list