N = 3 and RW = 2 not finding some keys

Russell Brown russell.brown at icloud.com
Fri May 18 08:13:27 EDT 2018


But why isn’t read repair “working”?

> On 18 May 2018, at 11:07, Bryan Hunt <bryan.hunt at erlang-solutions.com> wrote:
> 
> Of course, AAE will eventually repair the missing object replicas but it seems like you need something more immediate. 
> 
>> On 18 May 2018, at 11:00, Bryan Hunt <bryan.hunt at erlang-solutions.com> wrote:
>> 
>> Hi Guido, 
>> 
>> You should attempt to change the bucket property ‘notfound_ok’ from the default of ‘true' to ‘false'.
>> 
>> I.e 
>> 
>> curl -XPUT 127.0.0.1:10018/buckets/foo/props -H "Content-Type: application/json" -d '{"props":{"notfound_ok": false}}'
>> 
>> This makes GET operations for non-existent keys slower as it forces an internal GET for each of the three copies.
>> 
>> https://docs.basho.com/riak/kv/2.1.1/developing/app-guide/replication-properties/#the-implications-of-notfound-ok
>> 
>> From what you describe, it sounds like only a single copy (out of the original three), somehow remain present in your cluster.
>> 
>> Best Regards,
>> 
>> Bryan Hunt
>> 
>>> On 17 May 2018, at 15:42, Guido Medina <gmedina at temetra.com> wrote:
>>> 
>>> Hi all,
>>> 
>>> After some big rebalance of our cluster some keys are not found anymore unless we set R = 3, we had N = 3 and R = W = 2
>>> 
>>> Is there any sort of repair that would correct such situation for Riak 2.2.3, this is really driving us nuts.
>>> 
>>> Any help will be truly appreciated.
>>> 
>>> Kind regards,
>>> Guido.
>>> _______________________________________________
>>> riak-users mailing list
>>> riak-users at lists.basho.com
>>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>> 
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com




More information about the riak-users mailing list