(Sean, I was so glad to find Ripple -- just what we need for a proof-of-concept project we are starting.  Thank you!)<br><br>In trying to get things going with the Ripple sample code, I get the following error. Before I start ripping into it I thought I would see if anyone else had run into this... <br>
<br>curb library not found! Please `gem install curb` for better performance.<br>#<Riak::RObject <a href="http://127.0.0.1:8098/raw/doc/application.js">http://127.0.0.1:8098/raw/doc/application.js</a> [application/javascript]:"alert('Hello, World!')"><br>
/usr/local/lib/ruby/gems/1.9.1/gems/ripple-0.5.0/lib/ripple/document.rb:56:in `block in <module:Document>': uninitialized constant Email::EmbeddedDocument (NameError)<br>        from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.beta/lib/active_support/concern.rb:17:in `class_eval'<br>
        from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.beta/lib/active_support/concern.rb:17:in `append_features'<br>        from ./test.rb:27:in `include'<br>        from ./test.rb:27:in `<class:Email>'<br>
        from ./test.rb:26:in `<main>'<br><br>Test System Info<br>---------------------------<br>Ubuntu 8.04.3 LTS<br>ruby 1.9.1p376 (2009-12-07 revision 26041) [i686-linux]<br>gem version 1.3.5<br>(test.rb code is here:  <a href="http://gist.github.com/301963">http://gist.github.com/301963</a>)<br>
<br>*** LOCAL GEMS ***<br><br>abstract (1.0.0)<br>actionmailer (3.0.0.beta, 2.3.5)<br>actionpack (3.0.0.beta, 2.3.5)<br>activemodel (3.0.0.beta)<br>activerecord (3.0.0.beta, 2.3.5)<br>activeresource (3.0.0.beta, 2.3.5)<br>
activesupport (3.0.0.beta, 2.3.5)<br>addressable (2.1.1)<br>arel (0.2.pre)<br>builder (2.1.2)<br>bundler (0.9.3)<br>erubis (2.6.5)<br>gemcutter (0.3.0)<br>hobo (0.9.106)<br>hobofields (0.9.106)<br>hobosupport (0.9.106)<br>
i18n (0.3.3)<br>json_pure (1.2.0)<br>mail (2.1.2)<br>memcache-client (1.7.8)<br>mime-types (1.16)<br>rack (1.1.0, 1.0.1)<br>rack-mount (0.5.0, 0.4.0)<br>rack-test (0.5.3)<br>rails (3.0.0.beta, 2.3.5)<br>railties (3.0.0.beta)<br>
rake (0.8.7)<br>rillow (0.2.0)<br>ripple (0.5.0)<br>rubygems-update (1.3.5)<br>sqlite3-ruby (1.2.5)<br>terminal-table (1.4.2)<br>text-format (1.0.0)<br>text-hyphen (1.0.0)<br>thor (0.13.0)<br>tzinfo (0.3.16)<br>will_paginate (2.3.12)<br>
xml-simple (1.0.12)<br><br><br><br>Regards,<br><br>John Lynch, CTO<br>Rigel Group, LLC<br><a href="mailto:john@rigelgroupllc.com">john@rigelgroupllc.com</a><br><br><br><br>