Now I've got an ubuntu VM and I'm getting this error:<div><br></div><div>Command 'generate' not understood or not applicable</div><div><br></div><div><br><div class="gmail_quote">On Thu, Jun 21, 2012 at 5:48 PM, Nick Tune <span dir="ltr"><<a href="mailto:nick.tune@7digital.com" target="_blank">nick.tune@7digital.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="HOEnZb"><div class="h5"><br><br><div class="gmail_quote">---------- Forwarded message ----------<br>From: <b class="gmail_sendername">Nick Tune</b> <span dir="ltr"><<a href="mailto:nick.tune@7digital.com" target="_blank">nick.tune@7digital.com</a>></span><br>

Date: Thu, Jun 21, 2012 at 5:25 PM<br>Subject: Re: Cannot Install Riak<br>To: Bogunov <<a href="mailto:bogunov@gmail.com" target="_blank">bogunov@gmail.com</a>><br><br><br>Hello,<div><br></div><div>Thanks for the help. I made some progress and I got it working using the 1.1.2 build.</div>

<div><br></div><div>But I wanted to try multiple nodes on local machine which requires a build from source. Now I'm getting more issues.</div>
<div><br></div><div>Please see here: <a href="http://stackoverflow.com/questions/11139149/escript-riak-1-1-2-rel-riak-erts-5-8-5-bin-nodetool" target="_blank">http://stackoverflow.com/questions/11139149/escript-riak-1-1-2-rel-riak-erts-5-8-5-bin-nodetool</a></div>


<div><br></div><div>Thanks for your time. Sorry if I sound moody. This just annoyed me because I was so excited to play with riak and erlang. ah well - such is life.<div><div><br><div><br><div class="gmail_quote">
On Thu, Jun 21, 2012 at 5:23 PM, Bogunov <span dir="ltr"><<a href="mailto:bogunov@gmail.com" target="_blank">bogunov@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><p>Its possible what you don`t have one of required libraries, it seems you  are missing something from protobuf requirements, try building from scratch manually.<br>



just cd to protobuff dir and ./configure and make.<br>
<a href="tel:21.06.2012%2019" value="+12106201219" target="_blank">21.06.2012 19</a>:30 пользователь "Nick Tune" <<a href="mailto:nick.tune@7digital.com" target="_blank">nick.tune@7digital.com</a>> написал:</p>


<div><div><br>
><br>
> After pulling down riak from get, I get the following error when running make rel:<br>
><br>
> ./rebar compile generate<br>
> ==> cluster_info (compile)<br>
> ==> lager (compile)<br>
> ==> poolboy (compile)<br>
> ==> protobuffs (compile)<br>
> make: *** [rel] Error 1<br>
><br>
><br>
> I've had an awful experience getting riak setup. I've wasted two hours messing around and it still doesn't work. Please improve the experience for other users. <br>
><br></div></div><div>
> _______________________________________________<br>
> riak-users mailing list<br>
> <a href="mailto:riak-users@lists.basho.com" target="_blank">riak-users@lists.basho.com</a><br>
> <a href="http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com" target="_blank">http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com</a><br>
><br>
</div><p></p>
</blockquote></div><br></div></div></div></div>
</div><br>
</div></div></blockquote></div><br></div>