Hi,<div><br></div><div>I've spent many hours trying to figure out what's going on here with no resolution, any hint of where to look next would be greatly appreciated. <br><br>While trying to get riak 1.2.1-x86_64 started on Mac OS X Lion 10.7.5 to test it out and experiment, I'm running into this error: <br>

<br>$ riak start<br>Error reading /usr/local/Cellar/riak/1.2.1-x86_64/libexec/etc/app.config<br><br>Trying to use $escript app.config to debug this I get:</div><div><br></div><div><div>$ escript app.config</div><div>app.config:2: syntax error before: '['</div>

<div>escript: There were compilation errors.</div><br><div>I'm absolutely positive that this app.config is syntactically correct, as an exactly identical app.config works for people I know with a similar OS and configuration.</div>

<div><br>Here's the first five lines of code for the app.config:</div><div><br></div><div><div>%% -*- mode: erlang;erlang-indent-level: 4;indent-tabs-mode: nil -*-</div><div>%% ex: ft=erlang ts=4 sw=4 et</div><div>[</div>

<div> %% Riak Client APIs config</div><div> {riak_api, [</div></div><div><br>Thanks,<div><br></div><div>Sally L</div></div><br clear="all"><div><br></div></div>