<html><body><div style="color:#000; background-color:#fff; font-family:times new roman, new york, times, serif;font-size:12pt"><div><span><br></span></div><div style="color: rgb(0, 0, 0); font-size: 16px; font-family: 'times new roman', 'new york', times, serif; background-color: transparent; font-style: normal;"><span>Great, thanks Brian!</span></div><div><br></div>  <div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt;"> <div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt;"> <div dir="ltr"> <hr size="1">  <font size="2" face="Arial"> <b><span style="font-weight:bold;">From:</span></b> Brian Roach <roach@basho.com><br> <b><span style="font-weight: bold;">To:</span></b> Y N <yug3sh@yahoo.com> <br><b><span style="font-weight: bold;">Cc:</span></b> "riak-users@lists.basho.com" <riak-users@lists.basho.com> <br> <b><span style="font-weight: bold;">Sent:</span></b> Thursday,
 July 11, 2013 7:44 PM<br> <b><span style="font-weight: bold;">Subject:</span></b> Re: Riak 1.4 - Changing backend through API<br> </font> </div> <div class="y_msg_container"><br>
Heya.<br><br>That feature is code complete and awaiting peer review - the PR for it<br>is here: <a href="https://github.com/basho/riak-java-client/pull/250" target="_blank">https://github.com/basho/riak-java-client/pull/250</a><br><br>This will be part of the Java Client 1.4.0 release (with all the new<br>1.4 features) that I hope to have for next week.<br><br>Thanks,<br>Brian Roach<br><br>On Wed, Jul 10, 2013 at 2:06 PM, Y N <<a ymailto="mailto:yug3sh@yahoo.com" href="mailto:yug3sh@yahoo.com">yug3sh@yahoo.com</a>> wrote:<br>> Hi,<br>><br>> I just upgraded to 1.4 and have updated my client to the Java 1.1.1 client.<br>><br>> According to the release notes, it says all bucket properties are now<br>> configurable through the PB API.<br>><br>> I tried setting my backend through the Java client, however I get an<br>> Exception "Backend not supported for PB". Is this property not configurable<br>> through the API, or do I
 need a newer version of the Java client than 1.1.1?<br>><br>> Thanks.<br>><br>> _______________________________________________<br>> riak-users mailing list<br>> <a ymailto="mailto:riak-users@lists.basho.com" href="mailto:riak-users@lists.basho.com">riak-users@lists.basho.com</a><br>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com<br>><br><br><br></div> </div> </div>  </div></body></html>